PFsense dies in 10 minutes. Please Help!!



  • OK so I have been dealing with this problem for over two weeks now with still no resolution. I am hoping someone here can help.

    I have a ALIX2c3 board with 0.99 bios and pfSense 1.2 release on a brand new 1gb CF card with a 18v good working power supply.

    My network is setup as the following

    Internet -> Cable Modem -> ALIX2c3 -> D-Link 8port Gbe green Switch -> cat6 lan drops + wireless routers with dhcp disabled

    I can swap the ALIX2c3 in this network with a Linksys 802.11b router and the network works fine, wired, wireless, static ip's, dynamic ip's etc etc everything "works" it is just that my linksys router likes to be restarted every week or so due to torrent traffic etc. so I figured why not get a firewall/router to take it's place?

    so I have narrowed down my network issues by using various other switches, routers, computers and ip's etc etc. It is definitally the ALIX board that is causing problems.

    I have a serial connection to ALIX which ALWAYS works without fail. The web configuration and the internet connection for every pc, wired or wireless, dhcp or static, DIES after about 10 minutes. The LAN is still up as I can use my mac to remote into my windows box connected serially to ALIX. I then enter "5" to restart it and in about a minute or two everything works again… I repeat this process again and again...

    I need to figure out if this is a hardware or software issue. It is not an ISP issue as the 192.168.1.1 web configure fails along with the internet. I can still ping the address though.

    I have tired re-downloading, re-flashing, and re-installing pfSense. I have tired 1.2 release embedded, and 1.2.1 RC1 embedded.

    I have tried different flash cards.

    I have tried testing the powersupply

    The hardware seems to be working and the serial connection still works. This leads me to believe that the problem lies in pfSense as the web configure goes down but I still have access to the OS.

    What can I do to attempt to solve this problem? Has anyone else experienced problems with ALIX like this? Any help would be greatly appreciated.



  • @pcmofo:

    What can I do to attempt to solve this problem?

    I'm not ALIX user but how about to provide your dmesg/syslog thingy here first ???

    And someone has posted (seems to be) the same issue in the Hardware forum;
    http://forum.pfsense.org/index.php/topic,10995.0.html



  • So I spent a good 4 hours last night playing with my network. I unfortunately do not have a second switch, just the one brand new D-Link 8 port "green" Gbe switch. I do have a few wireless routers, a time capsule and some Fon routers though.

    I tried a few different combinations of setups with different routers and connecting via wired and wireless. I was able to connect my mac to the lan port of ALIX and get a solid connection.

    I then tried different routers in various configurations and ended up with a solid connection using a linksys b router as basically a switch for a wired connection to my mac and various other computers as well as wireless. I disabled dhcp on the linksys so that it would forward the request on to pfSense.

    This indicates to me one of two things…. I have a bad switch (which was working fine as far as I know) or ALIX/pfSense does not like my switch.... like maybe pfSense/ALIX has a hickup and the switch cant handle dropping the connection or something along those lines. I will try to scrounge up a switch from a friend in the mean time and test it out. It has been running 24 hours without problems in the current configuration though so I have hope that it is not entirely pfSense/ALIX's fault here.

    If anyone has suggestions as configurations to test or setting up my hardware let me know so I can get to the bottom of this.

    PS how would I post my syslogs?



  • Hi

    I would agree if the Linksys's lease interval or any other timer(even not configurable by users) which relates to dhcp, and pfSense didn't provide dhcp, then Linksys was the possible root cause. The Linksys had been trying to refresh its lease database in every 10 minutes so that you've lost your connection. Enabled dhcp again on Linksys, disable dhcp on pfSense, see if the issues happening again for the proof of your story.

    Posting logs are way easy. Hook up any term apps like teraterm/putty then cut&paste.



  • I have tera term connected. Is there a view logs option in the menu? I havent looked. Or is it in the web gui?

    It has been running so far for about 48 hours with no issues in the following configuration

    Internet -> Cable Modem -> ALIX -> Linksys wifi router acting as a switch -> wired computers.

    I ordered a 16 port Gbe netgear switch yesterday from newegg. It will be here later this evening so I will try my old configuration with the new switch and if it works fine then it was the switch. If not then I will try what you were saying with enabling and disabling dhcp on different devices. I will let you know how it works out later once I have it installed. Thanks!



  • Hi,

    @pcmofo:

    I have tera term connected. Is there a view logs option in the menu? I havent looked. Or is it in the web gui?

    well, what I meant was, you just drug the mouse and select you want to copy "a part of logs" within the teraterm's window, then go back to the browser's window you opened for this forum and right-click. Of course teraterm has its own log capability but it is not I'm saying, neither webgui.

    It has been running so far for about 48 hours with no issues in the following configuration

    That is good to hear. You must have been cleared nasty issues anyway ;D ;D ;D

    cheers,



  • Sounds like you're probably exhausting the state table, check your RRD graphs to see, and try increasing it.


Locked