Ldapusersearch - como filtrar um grupo com espaços e caracteres especiais



  • Boa tarde. Já busquei na net e não achei qual é a sintaxe usada no comando ldapuserserach para filtrar grupos do AD que tenham espaços e caracteres especiais como o Usuários do dominío. Sei que posso criar um outro grupo e colocar esse dentro, mas não acredito que essa seja a melhor prática. Alguém sabe onde encontro material que trate sobre a sintaxe desse comando?

    Cordialmente;



  • Pelo que vi tem a ver com url enconde (http://www.w3schools.com/tags/ref_urlencode.asp). Fazendo a conversão do grupo "Usuários do domínio" no site fica assim:

    Usu%C3%A1rios%20do%20dom%C3%ADnio

    Também tentei assim e nada:

    Usu%E1rios%20do%20dom%EDnio

    Alguém tem uma idéia do porque não da certo?
    Tem a opção de criar outro grupo sem caracteres especiais, mas o problema é que, sempre ao criar um usuário novo, tem que lembrar de adicionar nesse grupo.



  • O único que deu certo pra mim foi o %20 para espaço.
    Agora, se puder evitar qualquer caractere especial nos nomes das OUs ou Grupos acho melhor.



  • A sintaxe que usei na empresa e funcionou foi essa:

    ldapusersearch ldap://192.168.0.16:3268/DC=empresa,DC=corp?sAMAccountName?sub?(&(sAMAccountName=%s)(memberOf=CN=Acesso%20Internet%20-%20Nivel%201%20-%20Usuarios%20comuns%2cOU=SonicWALL%2cDC=empresa%2cDC=corp))



  • ldapusersearch "ldap://silviasaint.corp:3268/DC=silviasaint,DC=corp?sAMAccountName?sub?(&(sAMAccountName=%s)(memberOf=CN=N0%2cOU=Proxy%2cOU=Grupos de Operacao e Servico%2cOU=Infraestrutura%2cDC=silviasaint%2cDC=corp))"

    A unica diferença do amigo acima e as (""),  meus grupos pousem espaço  (Grupos de Operacao e Servico)



  • @iranrl:

    ldapusersearch "ldap://silviasaint.corp:3268/DC=silviasaint,DC=corp?sAMAccountName?sub?(&(sAMAccountName=%s)(memberOf=CN=N0%2cOU=Proxy%2cOU=Grupos de Operacao e Servico%2cOU=Infraestrutura%2cDC=silviasaint%2cDC=corp))"

    A unica diferença do amigo acima e as (""),  meus grupos pousem espaço  (Grupos de Operacao e Servico)

    Na versão 2.3.2 pra mim só funcionou sem as aspas ("") e com os caracteres especiais %20 para os espaços.
    Quando utilizava a verão 2.2.4 funcionava desta forma que vc colocou.


Log in to reply