Options for PPPoE are never saved and returns back to Static



  • When I go to Interfaces -> WAN, and do a normal configuration for PPPoE (username, password, service name and Block Bogon Networks set to disabled), when I click on Save, it keeps the username, password and service name, but Type revert back to "static" and Block Bogon Networks are enabled again.

    When I get disconnected by my ISP, it does not automatically reconnect (since it thinks the IP is static) and I have to manually change the Type and Block Bogon Network options then click on save. It then works fine until the next disconnection.

    It seems to be related to the problem discussed in the following topic:

    http://forum.pfsense.org/index.php/topic,10981.0.html

    Or this could explain the problem described in this topic…

    I am using the following version: 1.3-ALPHA-ALPHA built on Wed Aug 27 20:21:57 EDT 2008
    installed from scratch (not upgraded from 1.2)

    Can anyone else confirm the problem or I'm better to reinstall from scratch to fix this issue?  :-\

    Thanks
    ArkAngel



  • The issue seems to be fixed in the version from: Sat Aug 30 20:20:36 EDT 2008

    Thank you for fixing this issue!
    ArkAngel



  • Thanks!

    Indeed, confirmed.

    cheers,



  • Strangely enough, it worked for a few days, then this morning the problem was back. I haven't done any firmware update and haven't changed any setting inbetween. Maybe that was just a coincidence that it worked fine, or maybe I haven't verified enough  ::)

    So I updated to the latest firmware available (Thu Sep  4 19:14:37 EDT 2008) but nothing changed, same problem still there.

    A fix for this annoying bug would be much appreciated. I understand this version is not for production (I installed it at home), but don't you like to have many users testing your alpha versions?

    Maybe I'm posting in the wrong place to be heard? I haven't seen a BugReport form anywhere and all documentation regarding this alpha version are pointing to this forum.

    Thank you,
    Ark



  • Yeah Yeah…same here. Not just this one but also SVG/RRD are need to be corrected. That's strange enough but also it's only -AA quality, keep updating 'till issues are gone  :P (snapshots are now absent though...)

    cheers,



  • Try the next snapshot i think this should be fixed.



  • I think my info maybe help you!

    1st:
    1.new install 1.2 from live-cd
    2.download the latest upgrade package and upgrade the system
    3.config the wan used pppoe;The PPPOE can't connect the peer;MDP say my secret is null?

    2nd: i reinstall the system used 1.2-live-cd
    1.config the wan used pppoe;Then ADSL connected the peer
    2.upgrade the system used the latest package
    3.connect the adsl peer; Everything is OK

    Final
    In Vmware,I install a new system use 1.2 live-cd
    Then I upgrade the system without any configure;
    when config the system,and connect the adsl peer;system say "secret is null"

    So  I find the system's config.xml and compare them.
    The normal config like this:
    <username>Adslusername</username>
    <password>password</password>
    The error one like this:
    <pppoe_username>adslusername</pppoe_username>
    <pppoe_password>password</pppoe_password>

    So,the Upgrade change the PPPOE parameter-name?



  • Yeah  i missed that. I fixed this in cvs so the next snapshot should be ok.

    Thanks for the info.



  • @ermal:

    Yeah  i missed that. I fixed this in cvs so the next snapshot should be ok.

    Wonderful! Fixed all the way! Had excellent reliability lately with the buils!

    Keep up the good work guys! And thanks for the fix!

    ArkAngel


Locked