Netflix blocked when using open vpn but not like every other thread I've found.



  • So I have open vpn setup and ONLY traffic from one transmission jail on my freenas BOX is set to route through the VPN gateway. Confirmed working as intended. The transmission jail shows a public IP from the VPN and ALL other devices on my network show a public IP from my WAN  ISP,  TWC.

    Next I've read many threads on forcing Netflix traffic through Wan with a rule and tried (despite this not being necessary with my setup). PC's work fine on Netflix through a browser but both of my Roku boxes give me the proxy error msg so common with ppl trying to use Netflix through a VPN.  But I'm not. I simply have a VPN connection active on my network but not passing any traffic from Roku through it,  let alone Netflix. If I deactivate the client VPN interface everything works normally.    Is Netflix really blocking me because it sees a VPN on my network,  can they really do that even?



  • New findings: Depending on what public IP detection site I go to on my PC I get either the true WAN IP (as intended) or the VPN IP. Geolocation tools mostly show the VPN location rather. Again all traffic except a small pool of LAN IP's is not directed through the VPN.
    computers with an IP in the VPN alias always show the VPN IP and location.  I just have a rule under LAN that says alias traffic use VPN gateway. Thoughts? Why am I getting two different results using different websites?



  • solved: one tutorial I used had me copy all default rules and switch the copies to the VPN gateway instead of WAN. This was causing the issue because the rules were not in the correct order and not needed at all. Only the single rule was needed in my case to allow certain IP's to go through the VPN.


  • LAYER 8 Global Moderator

    "one tutorial I used had me copy all default rules and switch the copies to the VPN gateway instead of WAN"

    There is a lot of crap by a lot people that don't really have a clue out there - they click something and think something is working so they post about it ;)  I really would take any sort of guide/help/tutorial you find on the net with a grain of salt.  It might be good, but more than likely its crap that is dated anyway from version 2.0 or 2.1 of pfsense, etc.



  • No doubt, that's why upon looking at multiple writeups I didnt see all of them doing it the same. I started taking all the different parts and figuring out exactly why and what was being done. Learned a lot in the process.

    Although another reason it wasn't working was that anytime I put "route-nopull" into my advanced config VPN client section my squid proxy was making all traffic coming from the box I wanted to be routed though the VPN to not appear to be coming from its IP. So for anyone reading in the future make sure you put the specific IP that you want to use the VPN into the proxy bypass list or some other method. Working perfectly now.



  • Sound like: It could be because of the wrong setup, but as you explained It doesn’t seem like any issue or most probably it will be detected by Netflix systems, which is extremely restricted for VPN IP’s these days. Netflix recently joined hands with PayPal to track down VPN providers through their IP’s.

    Suggestion: Try to get Smart DNS which is the alternate to access Netflix. ExpressVPN one of the leading survival of the http://www.vpnlogics.com/best-vpn-for-netflix/ list, which will also provide free Smart DNS with VPN service. Also, you can configure easily or they will do it for you. that’s all.



  • Hey, could you share your rules with me? I've been trying over and over but I cant get this to work.


Log in to reply