2.3.2-p1 - custom dnsmasq.conf no longer being used



  • So, I applied the update without catching that the following would have a big impact to my configuration:

    Added "-C /dev/null" to the dnsmasq command line parameters to avoid it picking up an incorrect default configuration which would override our options.

    I use dnsmasq extensively (for ad and malware  blocking) and it appears that the dnsmasq.conf file I place in /usr/local/etc is no longer getting picked up.

    Is there a way I can get it to start using my custom conf file again?

    Any help appreciated.


  • Rebel Alliance Developer Netgate

    We never intended for that file to be picked up, and the fact that it was picked up was breaking some configurations.

    If you rely on that behavior, you'll have to edit the source and reverse that change. You should be able to take the commit linked on the ticket and use the system patches package to revert it.



  • @s0dhi:

    So, I applied the update without catching that the following would have a big impact to my configuration:

    Added "-C /dev/null" to the dnsmasq command line parameters to avoid it picking up an incorrect default configuration which would override our options.

    I use dnsmasq extensively (for ad and malware  blocking) and it appears that the dnsmasq.conf file I place in /usr/local/etc is no longer getting picked up.

    Is there a way I can get it to start using my custom conf file again?

    Any help appreciated.

    All you have to do is edit /etc/inc/services.inc and search for the dnsmasq entry in that file and remove the "-C /dev/null" part of that line (without the quotes of course). Then save the file and restart the dnsmasq service.
    This freaked me out as well and took me a few minutes to understand that they changed things which broke my simple yet effective (meaning very fast) adblocking routine. Hope this helps you too!


Log in to reply