FIXED>Dashboard update showing 2.3.2_1 avail YET I did install it



  • Saw update for 2.3.2_1 available. Updated but had to do twice as it failed on part of it the first time and then continued second try where it finished.

    Later on I chose to reset to factory default and reboot as I had decided to restore a recent config that I backed up and was happy with. I also sometimes do this when switching between 128bit to 256bit OpenVPN configs that I have setup. This time it was simply to just refresh everything.

    Anyway, I am getting notified that update 2.3.2_1 is available from the Auto Dashboard Update. When I click the download button, it takes me to a page that checks the version and tells me I'm updated.

    The message of the new update being available (when it's already installed) continues to happen.

    Not having a huge issue with this but hoping that someone can confirm that the next update will still notify and this didn't mean something is broken.

    Also, was there something in the restored config (from last 232 version) that broke the accurate reporting of update available.



  • I have the same problem. Updated from 2.3.2 to 2.3.2_1 just a few hours ago and rebooted. Had to install via the console and took about 10 tries as package downloads kept timing out, but did eventually work. Only thing I've done since is install the ntopng package (and had to do a pkg update -f as I was getting a package size mismatch error) and have noticed the dashboard reports running 2.3.2 and new version available, but update and it confirms latest version.



  • Only thing I didn't mention in regards to doing the recent config restore was that I too tried to install a package (Snort) and had messages ("after" the latest pfsense update)  of "mismatch".  It was one of the reasons I did a factory reset then restored a clean config. I'm assuming doing so (factory reset) also deletes any bad install routines and/or leftovers.

    Had previously had issues installing Snort as well as Squid in the previous version and essentially did the same procedure as mentioned above when this happened.

    To be clear… I am NOT running any packages and the intial install & pfsense deployment is actually very recent.

    What is pkg update -f command, use and it's purpose?

    Finally, I am reasonably tech knowledgable and a fast learner but a bit of a pfsense virgin. I DO love Pfsense from what I've seen so far. Decision to go with a dedicated box was my experiments with DD-WRT (granted was an older 1gb Netgear 3800v2 for the experiment) and it was disappointing. With the dedicated Pfsense firewall/OpenVPN/router box I am getting ZERO reduction in internet speeds with my 150mbps account.

    Thanks



  • Update to last post:

    I ran
    pkg clean -ya

    then ran
    pkg update -f command

    then did a reboot since original post and is still showing the installed 2.3.2_1 as being available. The above commands did, however, appear to have cleaned the failed snort & squid packages that had previously failed.



  • I was able to fix the version info.  Not sure if there is a step or two here not required but here is what I did.

    I downloaded SecureCRT.

    Logged in to shell and ran:

    pkg clean -ya
    pkg upgrade
    pkg update -f

    then reboot

    Not sure if was exactly in that order BUT the combination of this worked when I rebooted Pfsense and now says I'm current regarding Pfsense versions (as well as all packages)  ;D.

    Hope this helps.



  • Thank you so much, securityconscious! This seemed to fix the problem for me as well! I just signed up for the forums this morning when I discovered that I was having the same problem. Whatever these commands did fixed the issue for me.



  • Happy this all worked for you too.

    BTW, I also did a restore with my clean configuration and all is good too :-).

    CHEERS!



  • I used these suggestions for a 2.3.2 to 2.3.4 update after failing many other ways.

    THANK YOU, this worked