Error upgrading from 2.3.2 to 2.3.2_1



  • 2.3.2-RELEASE (i386)
    built on Tue Jul 19 13:09:39 CDT 2016
    FreeBSD 10.3-RELEASE-p5

    Upgrade to Version 2.3.2_1

    This is the logs:

    
    >>> Updating repositories metadata... 
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue...
    pfSense repository is up-to-date.
    All repositories are up-to-date.
    **** WARNING ****
    Duplicate slice required!!
    
    Before starting the upgrade process, the currently mounted nanobsd partition
    needs to be cloned to the secondary partition, where the update will happen
    
    After installation a reboot will be required to switch partition.
    
    >>> Cleaning secondary partition... done.
    >>> Duplicating current slice... done.
    >>> Restoring slice label... done.
    >>> Testing duplicated partition integrity... done.
    >>> Mounting second partition to run upgrade... done.
    >>> Copying resolv.conf to upgrade partition... done.
    >>> Unlocking package pfSense-kernel-pfSense_wrap... done.
    >>> Downloading upgrade packages... 
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue...
    pfSense repository is up-to-date.
    All repositories are up-to-date.
    Checking for upgrades (42 candidates): .......... done
    Processing candidates (42 candidates): .......... done
    The following 42 package(s) will be affected (of 0 checked):
    
    Installed packages to be UPGRADED:
    	php56-zlib: 5.6.23 -> 5.6.26 [pfSense]
    	php56-xmlwriter: 5.6.23 -> 5.6.26 [pfSense]
    	php56-xmlreader: 5.6.23 -> 5.6.26 [pfSense]
    	php56-xml: 5.6.23 -> 5.6.26 [pfSense]
    	php56-tokenizer: 5.6.23 -> 5.6.26 [pfSense]
    	php56-sysvshm: 5.6.23 -> 5.6.26 [pfSense]
    	php56-sysvsem: 5.6.23 -> 5.6.26 [pfSense]
    	php56-sysvmsg: 5.6.23 -> 5.6.26 [pfSense]
    	php56-sqlite3: 5.6.23 -> 5.6.26 [pfSense]
    	php56-sockets: 5.6.23 -> 5.6.26 [pfSense]
    	php56-simplexml: 5.6.23 -> 5.6.26 [pfSense]
    	php56-shmop: 5.6.23 -> 5.6.26 [pfSense]
    	php56-session: 5.6.23 -> 5.6.26 [pfSense]
    	php56-readline: 5.6.23 -> 5.6.26 [pfSense]
    	php56-posix: 5.6.23 -> 5.6.26 [pfSense]
    	php56-pdo_sqlite: 5.6.23 -> 5.6.26 [pfSense]
    	php56-pdo: 5.6.23 -> 5.6.26 [pfSense]
    	php56-pcntl: 5.6.23 -> 5.6.26 [pfSense]
    	php56-openssl: 5.6.23 -> 5.6.26 [pfSense]
    	php56-opcache: 5.6.23_1 -> 5.6.26_1 [pfSense]
    	php56-mcrypt: 5.6.23 -> 5.6.26 [pfSense]
    	php56-mbstring: 5.6.23 -> 5.6.26 [pfSense]
    	php56-ldap: 5.6.23 -> 5.6.26 [pfSense]
    	php56-json: 5.6.23 -> 5.6.26 [pfSense]
    	php56-hash: 5.6.23 -> 5.6.26 [pfSense]
    	php56-gettext: 5.6.23 -> 5.6.26 [pfSense]
    	php56-filter: 5.6.23 -> 5.6.26 [pfSense]
    	php56-dom: 5.6.23 -> 5.6.26 [pfSense]
    	php56-curl: 5.6.23 -> 5.6.26 [pfSense]
    	php56-ctype: 5.6.23 -> 5.6.26 [pfSense]
    	php56-bz2: 5.6.23 -> 5.6.26 [pfSense]
    	php56-bcmath: 5.6.23 -> 5.6.26 [pfSense]
    	php56: 5.6.23 -> 5.6.26 [pfSense]
    	pfSense-rc: 2.3.2 -> 2.3.2_1 [pfSense-core]
    	pfSense-kernel-pfSense_wrap: 2.3.2 -> 2.3.2_1 [pfSense-core]
    	pfSense-default-config-serial: 2.3.2 -> 2.3.2_1 [pfSense-core]
    	pfSense-base-nanobsd: 2.3.2 -> 2.3.2_1 [pfSense-core]
    	pfSense: 2.3.2 -> 2.3.2_1 [pfSense]
    	perl5: 5.20.3_13 -> 5.20.3_15 [pfSense]
    	libxml2: 2.9.3 -> 2.9.4 [pfSense]
    	libidn: 1.31 -> 1.33_1 [pfSense]
    	curl: 7.49.1 -> 7.50.3 [pfSense]
    
    Number of packages to be upgraded: 42
    
    56 MiB to be downloaded.
    Fetching php56-zlib-5.6.26.txz: .. done
    Fetching php56-xmlwriter-5.6.26.txz: .. done
    Fetching php56-xmlreader-5.6.26.txz: .. done
    Fetching php56-xml-5.6.26.txz: .. done
    Fetching php56-tokenizer-5.6.26.txz: . done
    Fetching php56-sysvshm-5.6.26.txz: . done
    Fetching php56-sysvsem-5.6.26.txz: . done
    Fetching php56-sysvmsg-5.6.26.txz: . done
    Fetching php56-sqlite3-5.6.26.txz: .. done
    Fetching php56-sockets-5.6.26.txz: .... done
    Fetching php56-simplexml-5.6.26.txz: ... done
    Fetching php56-shmop-5.6.26.txz: . done
    Fetching php56-session-5.6.26.txz: ... done
    Fetching php56-readline-5.6.26.txz: .. done
    Fetching php56-posix-5.6.26.txz: . done
    Fetching php56-pdo_sqlite-5.6.26.txz: .. done
    Fetching php56-pdo-5.6.26.txz: ..... done
    Fetching php56-pcntl-5.6.26.txz: .. done
    Fetching php56-openssl-5.6.26.txz: ..... done
    Fetching php56-opcache-5.6.26_1.txz: ...... done
    Fetching php56-mcrypt-5.6.26.txz: .. done
    Fetching php56-mbstring-5.6.26.txz: .......... done
    Fetching php56-ldap-5.6.26.txz: .. done
    Fetching php56-json-5.6.26.txz: .. done
    Fetching php56-hash-5.6.26.txz: .......... done
    Fetching php56-gettext-5.6.26.txz: . done
    Fetching php56-filter-5.6.26.txz: .. done
    Fetching php56-dom-5.6.26.txz: ...... done
    Fetching php56-curl-5.6.26.txz: ... done
    Fetching php56-ctype-5.6.26.txz: . done
    Fetching php56-bz2-5.6.26.txz: .. done
    Fetching php56-bcmath-5.6.26.txz: .. done
    Fetching php56-5.6.26.txz: .......... done
    Fetching pfSense-rc-2.3.2_1.txz: . done
    Fetching pfSense-kernel-pfSense_wrap-2.3.2_1.txz: .. done
    pkg: https://pkg.pfsense.org/pfSense_v2_3_2_i386-core/All/pfSense-kernel-pfSense_wrap-2.3.2_1.txz: Operation timed out
    >>> Locking package pfSense-kernel-pfSense_wrap... done.
    Failed
    
    

    Someone can help me?

    Thanks.



  • Same situation.
    Both with webgui and shell

    :-[ :-[



  • Same here too.

    Same package failing as well: pfSense-kernel-pfSense_wrap-2.3.2_1.txz

    If I hit the URL direct using a browser on a different machine, the package downloads OK



  • Hello,
    Happened to me last night with the update. 3 times in a row but i managed to make the update after a system restart. Luckily no one was at office at that time and restart the machine.


  • Rebel Alliance Developer Netgate

    Can you try again now? We have made some adjustments to the update server load balancing.



  • I had this error too, retried it a few times and eventually it went passed it and upgraded without a problem.



  • I've had the same errors. I've disabled DNS Resolver, did the upgrade successfully and then enabled it back.



  • @jimp:

    Can you try again now? We have made some adjustments to the update server load balancing.

    Still the same problem here:

    
    Fetching pfSense-kernel-pfSense_wrap-2.3.2_1.txz: ... done
    pkg: https://pkg.pfsense.org/pfSense_v2_3_2_i386-core/All/pfSense-kernel-pfSense_wrap-2.3.2_1.txz: Operation timed out
    >>> Locking package pfSense-kernel-pfSense_wrap... done.
    Failed
    
    


  • Update finished successfully:

    
    >>> Setting secondary partition as active... done.
    Upgrade is complete.  Rebooting in 10 seconds.
    >>> Locking package pfSense-kernel-pfSense_wrap... done.
    Success
    
    

    Thanks!


Log in to reply