Second WAN IP not working



  • Hi, I'm a new pfsense user and I am having some difficulty with vips.  What I have is a 192.168.0.0/24 LAN and I want to be able to use the 2 IPs my dsl provider gives me (non pppoe).  I configured pfsense to use xxxx.xxxx.xxxx.111/24 for the WAN.  I then created a proxy arp vip for xxxx.xxxx.xxxx.30.  The 2 ips are on the same subnet and are both /24 ips.  I created a http port forward for .111 and that works fine.  I then created a http port forward for .30 and it doesn't work at all.  I want to have each external IP port forward to 2 seperate web servers.  I also created several other port forwards on .111 (smtp, rdp, citrix, pptp) and they all work great.  Firewall rules were created along with all port forwards.  The .30 vip doesn't work at all.  I then tried using CARP and had the same results with that.  Is it possible that the .30 ip is not working because there is no outgoing traffic on it and therefore the mac address doesn't register for that ip?  Any help would be appreciated.

    Thanks



  • I am having a similar problem but found that setting the virtual ips to be carp fixes it for a little while but crashes the system (my system at least)



  • http://forum.pfsense.org/index.php/topic,7001.0.html

    How did you test that the VIP is "not working"?

    Also if you've been using CARP. Did you set the correct subnet?



  • hmm, let me see.  I tried to access the .30 ip from a web browser on a totally separate internet connection in a completely separate building.  I am already aware that I am not able to access vips from within the LAN.  I am also aware that local services cannot bind to PARP addressses.  I wouldn't of posted my question if I didn't already search.

    Thank you.


Log in to reply