Very Strange NIC Problem. Doesn't work but it works ! .



  • Hello everyone ,
    I do have very strange problem with my friend's little box which has two Realtek GBE integrated nics
    re0,re1 .

    re0 is detected but it doesn't work at all ( not getting an ip from dhcp , doesn't work as dhcp server ,pppoe …)
    Well , if for example I assaigned re0 to be LAN with 192.168.1.1 .
    in console screen I still can see

    re0 -> v4: 192.168.1.1/24
    

    but the adapter doesn't respond to dhcp clients , in windows network adapters I just see identifying  … then I don't get any ip .

    while re1 works in all situations , as ppoe/lan/wan .
    the strange thing that they are the same model of nics with same version/driver!

    I've tried everything from messing with BIOS settings / re-installs , different USB sticks
    NANOBSD/Full-version but nothing helped .

    I do have almost the same box as my friend's one (same mobo/nics/cpu), I've copied my bios and flashed it into his one.
    but the same result. while my box is working without issues.

    So, It definitely looks like a hardware issue BUT, I've tried Linux live-cd and re0 is working fine !
    restarted the PC, then it's also working in PfSense without changing the previous settings !
    now this was the time to reset it to factory defaults to reconfigure it in my friends home.
    the same issue came back after turning the pc there. I've reinstalled PfSense again but same problem.
    tried linux live-cd once
    then it's working again !
    I figured out that if I reinstalled PfSense or have reset it to factory defaults
    it won't work until running the live-cd at least once .

    now it's working fine for 2 days , reboots/shutdowns doesn't make issues .
    but for sure I've tried again to restore to defaults and the issue came back .
    what could be the problem ??


Log in to reply