Static ARP entries for Hosts in different subnets



  • Hi,
    I need to set static ARP entries for a few hosts. Currently those hosts use pfsense as a gateway through different virtual ips on its lan interface. I set it up so I can have different hosts using different gateways according to the source ip addresses.
    I wrote a script and put it in /usr/local/etc/rc.d and it sets the static ARP entries using "arp -s". However im trying to do it the "legitimate" way using the DHCP server - but it only supports the subnet of the lan interface when I add statis arp entries there. Is there some way to add static arp entries for different subnets in the webgui ? Thx.



  • Here's the reason why I had to set static MACs in the ARP Table…
    Seems like the Supermicro board is switching MACs around... Hardware error ?
    These commands were executed within 1-2 seconds...

    Pfsense:

    [2.4.0-DEVELOPMENT][admin@pfSense.localdomain]/root: arp -d 192.168.1.18 ; arp 192.168.1.18
    192.168.1.18 (192.168.1.18) deleted
    ? (192.168.1.18) at 00:0c:29:2e:1b:d2 on vmx0 expires in 1200 seconds [ethernet]
    [2.4.0-DEVELOPMENT][admin@pfSense.localdomain]/root: arp -d 192.168.1.18 ; arp 192.168.1.18
    192.168.1.18 (192.168.1.18) deleted
    ? (192.168.1.18) at 00:0c:29:2e:1b:dc on vmx0 expires in 1200 seconds [ethernet]

    Ubuntu linux:

    root@sebi-ubuntu-virt:~# arp 192.168.0.9; arp -d 192.168.0.9; ping -c1 192.168.0.9; arp 192.168.0.9
    Adresse Hardware-Typ Hardware-Adresse Optionen Maske Schnittstelle
    192.168.0.9              ether  00:0c:29:2e:1b:dc  C                    eth0
    PING 192.168.0.9 (192.168.0.9) 56(84) bytes of data.
    64 bytes from 192.168.0.9: icmp_seq=1 ttl=64 time=0.478 ms

    –- 192.168.0.9 ping statistics ---
    1 packets transmitted, 1 received, 0% packet loss, time 0ms
    rtt min/avg/max/mdev = 0.478/0.478/0.478/0.000 ms
    Adresse Hardware-Typ Hardware-Adresse Optionen Maske Schnittstelle
    192.168.0.9              ether  00:0c:29:2e:1b:f0  C                    eth0



  • Ok I guess its a MPTCP "problem" switching the MACs ? Im experiencing the same thing on different hardware but running the same mptcp linux kernel…and the search continues. lol



  • Problem solved –- had to enable rp_filter in linux.


Log in to reply