• Hi Guys,

    This is my first post so please be gentle.
    I'm a bit of a noob to pfsense so apologies if this is a stupid question.

    My hardware is an Alix with Geode(TM) Integrated Processor by AMD PCS .

    When I run the web GUI update is fails so I ran the CLI update and it gives me this error.

    ….>>> Updating repositories metadata...
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue...
    pfSense repository is up-to-date.
    All repositories are up-to-date.
    **** WARNING ****
    Duplicate slice required!!

    Before starting the upgrade process, the currently mounted nanobsd partition
    needs to be cloned to the secondary partition, where the update will happen

    After installation a reboot will be required to switch partition.

    Proceed with upgrade? (y/N) y
    tee: /cf/conf/upgrade_log.txt: Read-only file system
    Secondary partition (/dev/ufs/pfsense1), used for upgrade not found

    I did a quick google and there was some talk of the filesystem not being read write even though the GUI shows.

    NanoBSD Boot Slice pfsense0 / ada0as2(rw)

    The Diag-> NanoBSD page shows.

    Read/Write status

    I hope you guys can help as I would really like to upgrade my box.


  • LAYER 8 Netgate

    What version are you upgrading FROM?

  • Hi there,



  • LAYER 8 Netgate

    (Duh - it's in your subject. Didn't see it there sorry.)

    I have seen a case or two where nano gets confused about which mode it is actually in. What happens if you run this from the console/ssh?

    mount -u /
    pfSense-upgrade -d

  • Hi,

    Still no good.

    tee: /cf/conf/upgrade_log.txt: Read-only file system
    Secondary partition (/dev/ufs/pfsense1), used for upgrade not found

    mount gives.

    /dev/ufs/pfsense0 on / (ufs, local, noatime, read-only, synchronous)
    devfs on /dev (devfs, local)
    /dev/md0 on /tmp (ufs, local)
    /dev/md1 on /var (ufs, local)
    devfs on /var/dhcpd/dev (devfs, local)

    If I use the command /etc/rc.conf_mount_rw it doesnt change it from being read only.

  • Gave up and rebuilt it in the end. Then restored my config from backup. Whole process took 30 mins after my CF card reader arrived.