SG-2440 - Not ufs & No /boot/loader after 2.3.2 -> 2.3.2-p1 upgrade



  • Hi,

    I have my SG-2440 just little over year now and all updates went fine up to now.
    I performed an upgrade from the WebGUI of my SG-2440.
    I got a mail that the upgrade was complete but the browser didn't seem able to connect anymore.
    The WAN and LAN lights of connected ports were flickering very fast.
    I waited somewhat around 5-10 minutes after pulling power.
    The power led turn red and then green, after a few seconds the WAN and LAN lights start flickering again very fast.

    When connecting to the console I see following message when booting:

    Google, Inc.
    Serial Graphics Adapter 01/27/15
    SGABIOS $Id: sgabios.S 8 2010-04-22 00:03:40Z nlaredo $ (wenwang@localhost.localdomain) Tue Jan 27 18:10:24 UTC 2015
    Term: 80x24
    O4 0

    <several white="" lines="" trimmed="">SeaBIOS (version SageBIOS-20150506_164733-localhost.localdomain)

    iPXE (http://ipxe.org) 00:14.0 C100 PCI2.10 PnP PMM+ <id>iPXE (http://ipxe.org) 00:14.1 C200 PCI2.10 PnP PMM <id>iPXE (http://ipxe.org) 00:14.2 C300 PCI2.10 PnP PMM <id>iPXE (http://ipxe.org) 00:14.3 C400 PCI2.10 PnP PMM <id>Press F12 for boot menu.

    F1  pfSense

    F6 PXE
    Boot:  F1
    Not ufs
    Not ufs
    Not ufs
    No /boot/loader

    FreeBSD/x86 boot
    Default: 0:ad(0,a)/boot/kernel/kernel
    boot:
    Not ufs
    No /boot/kernel/kernel

    FreeBSD/x86 boot
    Default: 0:ad(0,a)/boot/kernel/kernel
    boot:</id></id></id></id></several>

    I assume I need to do a full clean install but the documentation here:
    https://portal.pfsense.org/docs/manuals/reference/create-flash-media.html
    https://portal.pfsense.org/docs/manuals/reference/reinstall-pfsense.html
    speak of a file I cannot seem to obtain anymore from my account.
    I activated the support that came with my device shortly after receiving it but never needed to use one of the 2 tickets.
    Also I didn't download the installer as I assumed this would be available.

    It seems I can use the image available for download from the pfSense site:
    pfSense-CE-memstick-ADI-2.3.2-RELEASE-amd64.img.gz
    but this isn't optimized for my SG-2440;

    I'm not sure how to best proceed now so appreciate any help.
    What a way to start a sunny Sunday :)

    Thanks in advance!


  • Rebel Alliance Developer Netgate

    The best way to proceed is to use pfSense-CE-memstick-ADI-2.3.2-RELEASE-amd64.img.gz to get your box back online.

    Though I'm at a loss to explain what could have happened during the upgrade that would have caused the errors you see at boot time. Proceed with booting from that memstick image and reinstalling and watch for any other errors that pop up as you progress.



  • Hi jimp,

    thanks a lot for your reply!
    I was abroad for work so couldn't test this earlier at home.

    I installed the CE image and that went fine, I was able to import my config and all is up and running now.

    I did however get following message which worries me a bit:

    I followed following guide to install pfSense again on my SG-2440:
    https://doc.pfsense.org/index.php/Installing_pfSense#Performing_a_Full_Install_.28ISO.2C_Memstick.29

    Should I be worried about this message?

    What is the best way to get the official optimized image for my SG-2440 that was on it when I first received it so I can manually upgrade to the latest afterwards?

    Thanks again for your help, I'm really glad everything is back online now :)