2.3.2 to 2.3.2_1 upgrade failed



  • Well, the worst has happened. Tried to apply the upgrade during our maintenance window today, and it hung. This is on a C2758, not that old.

    Console output stopped at "trying to mount root", so I power cycled the box, then it wouldn't get past the boot loader, stopping with a "BTX halted" message.

    Had to run out and buy a Ubiquiti edgerouter just to get a computer or two back on line. I guess the next step is to re-install, but I'm not sure of the distribution to use with this box. Netgate ADI, maybe?

    Thanks



  • hi all

    Juste for information.
    I had a litle same problem with update on my fp cluster.
    After a lot of retry update (10/15 times), the update finish well.
    All time don't finish on time out connection.

    be happy and have fun.

    ^^


  • Rebel Alliance Developer Netgate

    @david_speco:

    Console output stopped at "trying to mount root", so I power cycled the box, then it wouldn't get past the boot loader, stopping with a "BTX halted" message.

    Sounds like you were looking at the wrong console. Have you tried attaching to the serial port console to see what is output there?

    If it's a C2758, the regular memstick image will work. If you bought it from us and it was registered, you should be able to get the factory firmware version for it by logging into the portal.



  • We're up and running with the community software, mostly.

    If I wasn't in full blown panic mode I might have thought to look at the serial console, but unfortunately I didn't, so I'm not sure what was wrong.

    After I got a Ubiquiti edgerouter up and running so I had internet access, I downloaded the community image, it installed OK and booted OK. Configured the interfaces, and then tried to upload my backup config. Reboot hung at "Trying to mount root".

    Thinking it might be a disk failure, I replaced the SSD with a Samsung 850 EVO, re-installed which went OK, tried to upload my backup config, reboot hung at "Trying to mount root".

    So, I decided to rebuild the config at least partially from scratch. Re-did some by hand, some by cut and paste xml file, rebooting after every major change. No problem, root mounts faster than I can see the message :-)

    So, my hypothesis is that there is something in the old config, which has evolved since 2014 or so, that is hosering the box. Haven't found it yet, but I can't play any more because the box is back in production, although without the openVPN config and the ca and certificates. It'll have to do for now, as it'll be a couple of weeks before me and a long maintenance window come together again.

    Cheers!

    David


  • Rebel Alliance Developer Netgate

    After "Trying to mount root…" is when the primary console changes. Serial console would show you what's wrong, your config most likely has the primary console set to serial.



  • Ah! good to know. And yes, the primary console is serial.

    There seems to be no record of my purchase in September 2014, and my store account doesn't work any more either. No software for me :-)

    I've forwarded some docs to support, I'm hoping we can get this straightened out.

    Thanks!

    David



  • Meh.

    Even though I forwarded purchase records, I'm being told I can't get the software. The only thing available to me through the portal is SG and XG hardware.

    I guess 2 year old hardware isn't supported any more.

    Not good.

    David


Log in to reply