[GAME] PFENSE & RainbowSix Siege (solution)



  • Hello all,

    If you play to Rainbow Six Siege, like me, and you have a strict NAT.

    The solution to have a Open NAT, not very secure, is to enable the UPNP on LAN interface in Services > UPnP & NAT-PMP.

    Think to disable this option when you don't play.

    During my researches, Ive found this website : http://olausson.de/2-misc/14-rainbow-six-siege-port-forwarding-for-open-nat-type, this solution didn't work for me, but this guy search how to configure his NAT to open mode without activate UPNP. Im still searching how to play with an open or moderate nat without upnp.

    http://security.stackexchange.com/questions/118918/is-upnp-still-insecure

    Thank to Chris4916 for his help.  :)

    Enjoy.



  • Has anyone managed to make RB6 Siege's NAT to be rather moderate instead of strict?

    Ubisoft has update game's port documentation https://support.ubi.com/en-gb/Faqs/000023138/Connectivity-issues-in-Rainbow-6-Siege and even after opening all these ports (except 80 and 443) the game still says my NAT is strict. I've tried to hunt the actual prots by checking the logs but it rather uses a huge range of ports or I just couldn't find it propery.

    ps. I've tested with Windows' Firewall off and id had no effect what so ever.



  • @xelibri:

    Has anyone managed to make RB6 Siege's NAT to be rather moderate instead of strict?

    Ubisoft has update game's port documentation https://support.ubi.com/en-gb/Faqs/000023138/Connectivity-issues-in-Rainbow-6-Siege and even after opening all these ports (except 80 and 443) the game still says my NAT is strict. I've tried to hunt the actual prots by checking the logs but it rather uses a huge range of ports or I just couldn't find it propery.

    ps. I've tested with Windows' Firewall off and id had no effect what so ever.

    I have, it shows up as Moderate NAT now.

    Followed the instructions at the Gaming subforum Sticky Topic: "Problems with a game? TRY THIS FIRST" @ https://forum.pfsense.org/index.php?topic=6042.0.

    After changing, it went from Strict to Moderate.

    Not sure if it's needed, but I also kept UDP 6015 and TCP 14000 + 14008 Port Forward rules under Firewall > NAT.



  • @krackpot:

    @xelibri:

    Has anyone managed to make RB6 Siege's NAT to be rather moderate instead of strict?

    Ubisoft has update game's port documentation https://support.ubi.com/en-gb/Faqs/000023138/Connectivity-issues-in-Rainbow-6-Siege and even after opening all these ports (except 80 and 443) the game still says my NAT is strict. I've tried to hunt the actual prots by checking the logs but it rather uses a huge range of ports or I just couldn't find it propery.

    ps. I've tested with Windows' Firewall off and id had no effect what so ever.

    I have, it shows up as Moderate NAT now.

    Followed the instructions at the Gaming subforum Sticky Topic: "Problems with a game? TRY THIS FIRST" @ https://forum.pfsense.org/index.php?topic=6042.0.

    After changing, it went from Strict to Moderate.

    Not sure if it's needed, but I also kept UDP 6015 and TCP 14000 + 14008 Port Forward rules under Firewall > NAT.

    So I believe I implemented these changes correctly but I am still receiving the "Strict NAT" type in Rainbow Six Siege. The only thing that has given me open NAT so far is to Enable UPnP & NAT-PMP in services. I'm attaching a picture of the NAT rules as they are right now. Let me know if you have any ideas for solutions or need more info.