Default Route not Set from Web Interface - PFSense version 2.4.0.a.20160927.0622



  • Dear friends, good day!

    We are working hard since last week to try to deploy PFSense on our network.

    We tried to use 2.3.2-p1 version on Windows Server 2008 R2 Hyper-V, but this PFSense version does not recognize this virtualizer IDE virtual controller. We also tried some previous versions, but we also had some problems on PFSense installation.

    The only one version that worked on Windows 2008 R2 Hyper-V was 2.4.0.a.20160927.0622 version (DEVELOPER edition), by doing some ATPs (Alternate Technical Procedures - In clear portuguese "gambiarra" or, in english "workaround"), but this version also has one main problem: It does not add the default route to the WAN interface when configured from the web interface.

    We are working around  this issue by manually adding the default route to the virtual appliance.

    Does anyone knows how to add this default route from command line so that PFSense will configure it since startup?

    Thanks a lot for any help.



  • Do not use 2.4 for anything other then testing.
    It is not ready for production use.



  • @heper:

    Do not use 2.4 for anything other then testing.
    It is not ready for production use.

    Which version should I use with Windows Server 2008 R2 Hyper-V?

    PFSense does not provide none of the previous stable versions…


  • Rebel Alliance Developer Netgate

    It's a known issue affecting primarily static IP address WANs but also affecting some other subsystems: https://redmine.pfsense.org/issues/6828

    Set the IP address on WAN using DHCP or manually add the route at boot time with a shellcmd or similar.

    There are still several areas of 2.4 that are unfinished, so it is not intended for production use.



  • @rogeriosilva:

    We tried to use 2.3.2-p1 version on Windows Server 2008 R2 Hyper-V, but this PFSense version does not recognize this virtualizer IDE virtual controller. We also tried some previous versions, but we also had some problems on PFSense installation.

    What do you mean by "not recognize"?
    Could you provide a screenshot?

    And by the way, with 2008 server you should use only fixed size .VHD, not dynamic one.