[SOLVED] Getting half TWC download bandwidth



  • Hi. Need help troubleshooting a download speed issue.  My TWC plan is 200 Mbps Down / 20 Mbps Up.  When I physically connect a laptop to the cable modem, I'm getting about 230 Mbps. When connecting from behind my pfsense setup, I'm consistently getting 93 Mbps, wired.  I have never enabled traffic shaping. The only packages I have installed is AutoConfigBackup and OpenVPN-client-export.  Upload speed is correct.

    When I first installed pfsense, I was getting full bandwidth.  I don't recall the version. Might have been 2.2. I'm currently on pfsense 2.3.2 p1. System is lightly used. Not many devices.

    CPU utilization is nominal. There's about 264MB of memory free at the moment. No swap is being used. Rig setup below.

    pfsense 2.3.2 p1 amd64
    VMware ESXI 6.0
    Supermicro A1SRi-2758F 8 core Atom, 16GB RAM, 2 x 256GB SSD, 1 x 750GB HDD
    1 vcpu
    1GB of memory
    Provisioned 80GB SSD storage
    Uses onboard intel 1GB ESXI compatible nics. One WAN, one LAN per the pfsense VM setup guide.
    Box is way under utilized.

    Be glad to answer any questions. FYI - my Linux skills are noob, at best.

    Thanks.



  • bump



  • What does System Activity show while you're doing your speed tests? Is anything consuming a lot of CPU?



  • Hey Harvy66-  Thanks for the follow-up.

    CPU doesn't even hit 25% utilization during OOKLA's speed test. That was the first thing I checked. If it was having problems, I would have thrown another vCPU at it.

    Any other ideas?



  • Did you make any changes to the stock settings, like enable SYN proxy?



  • Thanks for the suggestion, Harvy66. I have not enabled any proxy…

    However, I just found the problem.

    For whatever reason, the LAN NIC associated with the ESXi vSwitch was not auto negotiating to gigabit ethernet, but showing the speed as 100MB Full Duplex.

    I forced it to 1000MB Full Duplex, reran the speed test and am now getting in excess of 233 Mbps on the download, as it should be. All is once again good with the world.  :-)

    Thanks again.