SG-2440 Constant Reboot



  • Hi all,

    I have a SG-2440 that is over a year old.  (Hence, out of support).  We use this as a our emergency backup firewall to our Dell PowerEdge running pfSense.  Yesterday, I had a horrid crash on our primary firewall.  Of course, Murphy's Law… The SG has been offline and unplugged for about a year.  Upon powering it up and after 5 minutes realizing nothing was working, I hooked up my laptop to the console and could see that it was constantly rebooting after the F1 prompt to load pf.

    My question...  Do I attempt reloading pfSense?  Or, as I suspect, is the embedded flash bad and I should just get a mSATA drive to install?

    (The reason I think the flash is bad is because 1 month after we bought it, I had the same problem after configuring it and unplugging it.  At the time, support helped me reload the system and explained that the unit "should" be shutdown gracefully before removing power.  I know I performed a graceful shutdown before unplugging last year.  So now I suspect the flash???)

    Thoughts?


  • Rebel Alliance Developer Netgate

    I'd reinstall it using the most recent CE ADI memstick image and see how it runs first.



  • Hi jimp,

    I tried re-installing from the Community Edition USB memstick installer.  But, it froze after "Booting…".

    Where can I find the CE ADI memstick image?  When I login to the Support Portal, my subscription is no longer active and don't see any links for downloading...


  • Rebel Alliance Developer Netgate

    The CE ADI memstick is on the regular downloads page on pfsense.org



  • Oh Duh…

    The "Netgate" description through me off.  That worked!

    Thanks for your help.  I guess I'll have to repeatedly test powering down and make sure it comes back up now.



  • Just wanted to follow up with my findings in case it helps someone else…

    I was able to reproduce my problem.  When I restored the entire config from my Dell pfSense install, the same problem happened.  So then I started over and started restoring 1 section at a time.  When I got to the "System" restore, I lost console access.  (Curiously, it took 2 reboots to show itself).  The problem was the serial settings from the Dell are 9600 and my terminal was still set at 115200.  That was the main issue.  Second, it tried downloading all my packages on reboot.  Since, I didn't have any Internet access, it took 5-10 minutes to timeout before I could gain access to the webgui.  I think that in combination with me cycling power caused the crash and repeated reboots.

    Now I need to document my procedure so this doesn't happen again the next time I need to quickly put it into production.

    Thanks for your help jimp!

    Jeff



  • Tad off topic, but any reason you're not running them in a failover pair using CARP?  As long as you have at least three public IP addresses (so basically not a residential connection) you could have both routers hot and keep them updated and not have to worry about restoring otherwise disparate configs.



  • Sorry for the late reply.  Just now read this…

    I have been thinking about using CARP.  IP addresses are a bit tight.  But, I could probably work around that.  My real concern was that I have a gateway group (2 Internet Connections) using failover (One is a cable backup and we only have 1 IP).  We are also utilizing Inbound Load Balancing.  I wasn't sure how/if CARP would handle that setup and at this point I am a bit nervous to try :-)


Log in to reply