2.3.2_1 Update causing issues with OpenVPN



  • Hello all,

    I have recently updated Pfsense from 2.3.2 to 2.3.2_1 on a test box
    I had OpenVPN running on 2.3.2 without any issues but after the update when I try to connect to OpenVPN I get the error "TLS handshake failed" and am unable to connect.

    Since it is a test box I decided to wipe everything and start from scratch to test things.

    First test
    Reinstall PfSense with configurations and OpenVPN.
    Tested OpenVPN. Connected without any issues.
    Applied 2.3.2_1 patch. Tried to reconnect OpenVPN. Received the same error.

    Second test
    Reinstall PfSense and configure.
    Apply 2.3.2_1 patch then install OpenVPN with it's configurations after patch.
    Attempt to reconnect OpenVPN. Still receive the error.

    Is anyone else having this issue or have any comments/questions?
    Any feedback is appreciated.

    Thank you.

    • Victoria


  • What client are you using?



  • @robi:

    What client are you using?

    Hello, I am not sure I understand your question. What client are you talking about?

    I am using OpenVPN on Pfsense. When I go to Client Export in OpenVPN I chose the windows installer.


  • Rebel Alliance Global Moderator

    I am running 2.3.2_p1 and was running 2.3.2 with openvpn and no issues.  I am currently connected for that matter.  Both as pfsense as a client connected to a vps server running openvpn-as and as a road warrior client connected to pfsense openvpn server.

    Without some actual details of your setup, and what exact errors your seeing.  I have to assume since your using the export that your trying to connect to pfsense from somewhere else.  What IP are you trying to connect too?  Sure your using pfsense public IP?  Are you using udp or tcp?  What port - do you actually see the connection to pfsense, or is the tls handshake error after some other error?

    What does the log on pfsense show, what does the log on your client show?