Dhcpd fails with configuration error on VLAN



  • Hi,

    I have a pair of pfsense boxes doing CARP just fine as long as I only have one LAN interface, but when I define a second interface as a different VLAN on the same LAN interface, and add dhcp for the second LAN, dhcp stops working, and the log shows:

    /status_services.php: The command '/usr/local/sbin/dhcpd -user dhcpd -group _dhcp -chroot /var/dhcpd -cf /etc/dhcpd.conf -pf /var/run/dhcpd.pid igb1 igb1_vlan42' returned exit code '1', the output was 'Internet Systems Consortium DHCP Server 4.3.4 Copyright 2004-2016 Internet Systems Consortium. All rights reserved. For info, please visit https://www.isc.org/software/dhcp/ /etc/dhcpd.conf line 38: secondary may not define load balance settings. split 128; ^ Configuration file errors encountered -- exiting If you think you have received this message due to a bug rather than a configuration issue please read the section on submitting bugs on either our web page at www.isc.org or in the README file before submitting a bug. These pages explain the proper process and the information we find helpful for debugging.. exiting.' 
    

    Any suggestions?



  • I deleted all the VLAN interfaces, and recreated everything. Now dhcpd keeps up, but pool status shows "normal" for the main LAN dhcp, but "unknown-state" for the VLAN on the primary, and " recover-wait" and "unkown-state" on the secondary.



  • Update: 2 rounds of rebooting both boxes seems to have gotten everything working.