Increase max-write-idle in lighty-webConfigurator.conf



  • Hi All,

    While trying to install the ntop package on pfSense 1.2 I ran into a 6 minute timeout from lighttpd.  The package was taking more than 6 minutes to download so the webgui aborted the installation.

    The default setting in lighttpd for server.max-write-idle is 360 seconds and since the conf file doesn't change the setting this is the default behaviour in the webgui.

    To work around this I modified /var/etc/lighty-webConfigurator.conf (for currently running system) and /etc/inc/system.inc (for future reboots) and set max-write-idle to 86400.  This suits me, but may not be to everyone's taste.

    Could the developers give this some thought and maybe:

    1. Set a fixed value that is larger than 6 minutes in system.inc
      or
    2. Add a configuration parameter so that end users can change the timeout

    Thanks
    Jonty


Log in to reply