Writing to routing socket: No such process error



  • Hi all,

    I always got this error. I don't have any idea what to do with this error.

    I post here my config but is a strait small config.

    What cause this error ?

    My WAN interface is on the VLAN3000
    My LAN interface is on VLAN 4000
    My OPT interface is on VLAN 2808

    My WAN is an static IP

    
     <pfsense><version>3.0</version>
    	 <lastchange><theme>nervecenter</theme>
    	 <system><optimization>normal</optimization>
    		<hostname>pfSense-router</hostname>
    		<domain>cimeq.qc.ca</domain>
    		 <dnsallowoverride><username>admin</username>
    		<password>$1$8VfKEGVL$DZdPuTzlzN1idQPFO0PAA.</password>
    		<timezone>Etc/GMT-5</timezone>
    		<time-update-interval>300</time-update-interval>
    		<timeservers>0.pfsense.pool.ntp.org</timeservers>
    		 <webgui><protocol>http</protocol></webgui> 
    		<disablenatreflection>yes</disablenatreflection>
    		<dnsserver>204.19.10.190</dnsserver></dnsallowoverride></system> 
    	 <interfaces><lan><if>vlan1</if>
    			<ipaddr>10.0.0.1</ipaddr>
    			<subnet>16</subnet>
    			 <media><mediaopt><bandwidth>100</bandwidth>
    			<bandwidthtype>Mb</bandwidthtype></mediaopt></media></lan> 
    		 <wan><if>vlan0</if>
    			 <mtu><ipaddr>204.19.10.2</ipaddr>
    			<subnet>32</subnet>
    			<gateway>204.19.10.1</gateway>
    			<blockpriv>on</blockpriv>
    			 <disableftpproxy><dhcphostname><media><mediaopt><bandwidth>100</bandwidth>
    			<bandwidthtype>Mb</bandwidthtype>
    			 <spoofmac></spoofmac></mediaopt></media></dhcphostname></disableftpproxy></mtu></wan> 
    		 <opt1><if>vlan2</if>
    			<descr>OPT1</descr></opt1></interfaces> 
    	 <staticroutes><pppoe><username><password></password></username></pppoe> 
    	 <pptp><username><password><local></local></password></username></pptp> 
    	 <bigpond><username><password><authserver><authdomain><minheartbeatinterval></minheartbeatinterval></authdomain></authserver></password></username></bigpond> 
    	 <dyndns><type>dyndns</type>
    		 <username><password></password></username></dyndns> 
    	 <dhcpd><lan><enable><range><from>10.0.0.10</from>
    				<to>10.0.0.245</to></range></enable></lan></dhcpd> 
    	 <pptpd><mode><redir><localip></localip></redir></mode></pptpd> 
    	 <ovpn><dnsmasq><enable></enable></dnsmasq> 
    	 <snmpd><syslocation><syscontact><rocommunity>public</rocommunity></syscontact></syslocation></snmpd> 
    	 <diag><ipv6nat><ipaddr></ipaddr></ipv6nat></diag> 
    	 <bridge><syslog><nat><ipsecpassthru><enable></enable></ipsecpassthru></nat> 
    	 <filter><rule><type>pass</type>
    			<descr>Default LAN -> any</descr>
    			<interface>lan</interface>
    			<source>
    				<network>lan</network>
    
    			 <destination><any></any></destination></rule></filter> 
    	 <shaper><ipsec><preferredoldsa></preferredoldsa></ipsec> 
    	 <aliases><proxyarp><cron><minute>0</minute>
    			<hour>*</hour>
    			<mday>*</mday>
    			<month>*</month>
    			<wday>*</wday>
    			<who>root</who>
    			<command></command>/usr/bin/nice -n20 newsyslog 
    		 <minute>1,31</minute>
    			<hour>0-5</hour>
    			<mday>*</mday>
    			<month>*</month>
    			<wday>*</wday>
    			<who>root</who>
    			<command></command>/usr/bin/nice -n20 adjkerntz -a 
    		 <minute>1</minute>
    			<hour>3</hour>
    			<mday>1</mday>
    			<month>*</month>
    			<wday>*</wday>
    			<who>root</who>
    			<command></command>/usr/bin/nice -n20 /etc/rc.update_bogons.sh 
    		 <minute>*/60</minute>
    			<hour>*</hour>
    			<mday>*</mday>
    			<month>*</month>
    			<wday>*</wday>
    			<who>root</who>
    			<command></command>/usr/bin/nice -n20 /usr/local/sbin/expiretable -v -t 3600 sshlockout 
    		 <minute>1</minute>
    			<hour>1</hour>
    			<mday>*</mday>
    			<month>*</month>
    			<wday>*</wday>
    			<who>root</who>
    			<command></command>/usr/bin/nice -n20 /etc/rc.dyndns.update 
    		 <minute>*/60</minute>
    			<hour>*</hour>
    			<mday>*</mday>
    			<month>*</month>
    			<wday>*</wday>
    			<who>root</who>
    			<command></command>/usr/bin/nice -n20 /usr/local/sbin/expiretable -v -t 3600 virusprot 
    		 <minute>*/60</minute>
    			<hour>*</hour>
    			<mday>*</mday>
    			<month>*</month>
    			<wday>*</wday>
    			<who>root</who>
    			<command></command>/usr/bin/nice -n20 /usr/local/sbin/expiretable -t 3600 snort2c 
    		 <minute>*/5</minute>
    			<hour>*</hour>
    			<mday>*</mday>
    			<month>*</month>
    			<wday>*</wday>
    			<who>root</who>
    			<command></command>/usr/local/bin/checkreload.sh 
    		 <minute>*/5</minute>
    			<hour>*</hour>
    			<mday>*</mday>
    			<month>*</month>
    			<wday>*</wday>
    			<who>root</who>
    			<command></command>/etc/ping_hosts.sh 
    		 <minute>*/140</minute>
    			<hour>*</hour>
    			<mday>*</mday>
    			<month>*</month>
    			<wday>*</wday>
    			<who>root</who>
    			<command></command>/usr/local/sbin/reset_slbd.sh</cron> 
    	 <wol><installedpackages><vlans><vlan><if>vr0</if>
    			<tag>3000</tag></vlan> 
    		 <vlan><if>vr0</if>
    			<tag>4000</tag></vlan> 
    		 <vlan><if>vr0</if>
    			<tag>2808</tag></vlan></vlans> 
    	 <revision><description>/wizard.php made unknown change</description>
    		<time>1220447427</time></revision> 
    	 <rrd><enable></enable></rrd></installedpackages></wol></proxyarp></aliases></shaper></syslog></bridge></ovpn></staticroutes></lastchange></pfsense> 
    
    

    Dumarjo



  • Ok ,
    I found my problem.  I set the wrong netmask. I set it to /32 instead of /24

    Dumarjo


Locked