WAN 2 DNS fails to work when WAN 1 goes down



  • Hello all i have been banging my head all weekend trying to get this to work…

    Im using 2.3.2-RELEASE-p1 (amd64)

    Here is my setup on imgur

    http://imgur.com/a/CI7nl

    WAN 1 --> COMCAST with static IP (50 Meg)

    WAN 2 --> ATT fiber with static IP (10 Meg)

    I have followed all the standard guides im sure every uses when setting up MultiWan
    https://www.youtube.com/watch?v=omuklZrzopM
    https://www.youtube.com/watch?v=CXFzDfxa0mg
    http://www.tecmint.com/how-to-setup-failover-and-load-balancing-in-pfsense/

    I have tried all of them yet i still get the same problem....
    When i disconnect WAN 1 ..... i can only ping ip addresses from WAN 2 but WAN 2 wont resolve any websites for me

    the MOST infuriating thing for me is this works when i use 1 of 2 options

    System --> Advanced --> Miscellaneous Enable Default gateway switching

    Of course the description says you really should not need to use this option

    "If the default gateway goes down, switch the default gateway to another available one. This is not enabled by default, as it's unnecessary in most all scenarios, which instead use gateway groups."

    The 2nd thing i can use to solve my issue i discovered in a forum post https://forum.pfsense.org/index.php?topic=108023.0

    Services --> DNS Resolver --> General Settings --> DNS Query Forwarding --> Enable Forwarding Mode
    https://doc.pfsense.org/index.php/Unbound_DNS_Resolver

    "Controls whether Unbound will query root servers directly (unchecked, disabled) or if queries will be forwarded to the upstream DNS servers defined under System > General or those obtained by DHCP/PPPoE/etc (checked, enabled). Forwarding mode may be enabled if the upstream DNS servers are trusted and also provide DNSSEC support. Forwarding mode is necessary for Multi-WAN configurations unless default gateway switching is enabled."

    So im supposed to only use this if im not using default gateway switching

    tl;dr
    My MultiWAN only works if i use either Default gateway switching or Enable Forwarding Mode
    Default gateway switching says "This is not enabled by default, as it's unnecessary in most all scenarios, which instead use gateway groups."
    and
    Enable Forwarding Mode says "Forwarding mode is necessary for Multi-WAN configurations unless default gateway switching is enabled."
    How is everyone getting MultiWAN working without using these options.. surely i must be doing something wrong...



  • First of all, you do not need to setup separate gateway groups for failover as well as firewall rules for the same. pFsense automatically uses the gateway currently online.
    Secondly, you did not select 'LAN net' in Source in LAN rules.
    Still need help ? Just give a quick reply.