DNS Issue - DNS Couldn't Resolve Hosts Sometime



  • Hi,

    I've brand new setup of pfsense. Simply I set as follows.

    a) IP and Gateway in WAN Interface
    b) DNS as 8.8.8.8 using gateway IP.
    c) Allow DNS server list to be overridden by DHCP/PPP on WAN - Unchecked
    d) Do not use the DNS Forwarder as a DNS server for the firewall - Check

    Please let me know how do I enable logs to identify the issue and post here? My internet is working fine because when I use router with same setting, no dns issue is happening.

    Regards,
    Sachin


  • LAYER 8 Global Moderator

    "b) DNS as 8.8.8.8 using gateway IP."

    So your using forwarder not the resolver, or you have the resolver in forwarder mode?



  • What do you mean by sometime?  Hourly?  Daily?  And what is having problems, pfsense itself or a LAN client?  The default install uses the DNS Resolver which does not need any upstream DNS defined.  It should just work.  Can you vierify that DNS Resolver is enabled and working?



  • Within couple of hours it happens.. Some page opens, some page doesn't… Then after 10-15 mins, it worked fine.

    All my clients are connected via LAN to pfsense and the problem happens with all the clients. Around 20 nodes. In all nodes, DNS is set to pfsense local IP (192.168.0.1)

    The default install uses the DNS Resolver which does not need any upstream DNS defined. --- How to check?

    Can you verify that DNS Resolver is enabled and working? -- How to check?


  • LAYER 8 Global Moderator

    is the resolver running or dnsmasq?  Look on the resolver is it enabled, or is the forwarder enabled?



  • Please find the screenshot attached..

    I use only IPv4.

    ![DNS Forwarder.PNG](/public/imported_attachments/1/DNS Forwarder.PNG)
    ![DNS Forwarder.PNG_thumb](/public/imported_attachments/1/DNS Forwarder.PNG_thumb)
    ![DNS Resolver.PNG](/public/imported_attachments/1/DNS Resolver.PNG)
    ![DNS Resolver.PNG_thumb](/public/imported_attachments/1/DNS Resolver.PNG_thumb)
    ![DNS Server.PNG](/public/imported_attachments/1/DNS Server.PNG)
    ![DNS Server.PNG_thumb](/public/imported_attachments/1/DNS Server.PNG_thumb)








    ![Homepage DNS.PNG](/public/imported_attachments/1/Homepage DNS.PNG)
    ![Homepage DNS.PNG_thumb](/public/imported_attachments/1/Homepage DNS.PNG_thumb)



  • Hi… Please let me know what i need to change in setting...



  • In the DNS settings under general Add your DNS server 192.168.0.1 before 8.8.8.8



  • If you're not using the Forwarder, and you're not using the Resolver in forwarding mode, then those DNS settings aren't used if I recall correctly.  I just looked through the thread again and I'm not seeing any evidence there is anything DNS-related.  He says sometimes he can't get to a website and then later he can.  He is either assuming it's a DNS issue or there was a specific error message about DNS that he didn't share with us.

    The next time it happens, use Diagnostics - DNS Lookup to check to see if you can resolve that hostname.



  • Dear Kom,

    i am also facing the same issue,  we are able to open every site. except "booking.com"  but some time its opens and when you click on any option then again the error comes "secure.booking.com’s server DNS address could not be found"  i really dont understan what is the issue. i tried to ping www.booking.com from my computer which is connected to pfsense via wifi.  it doesnt go.

    but some of the computer via lan or wan they access for sometime and later the same issue.  i went to dignositics/ dnslookup it resolve name to IP 5.57.16.220. pls let me know what can be the isssue.

    Regards,
    Himanshu Dua



  • 1. Please don't hijack other peoples's threads.

    2.  Sounds like just a transient DNS issue with that domain's DNS provider.  If it only happens with one site some of the time then I would assume the issue is on their end.


Log in to reply