No Navego Conectado A OPENVPN



  • Estimados

    Estoy presentando el siguiente problema con uno de os firewall que tengo instalados, es solo en uno y compare parámetros entre ellos y no encontré nada raro, el síntoma es que yo al conectarme remotamente por un acceso VPN que cree con openvpn , no tengo acceso a internet mientras estoy dentro de la vpn, esto me ocurre solo con un acceso de 4 que tengo en diferentes lados.

    En los otros equipos de conecto a la vpn y reviso la red local sin problemas y a la vez puedo navegar sin problemas, pero de uno solo puedo revisar la red local y no tengo acceso a internet, siendo que es algo que se ocupa si estoy viendo errores o buscando algo importante .

    Estaré atento a su respuesta para saber que puede estar sucediendo. Saludos gratos.



  • Por favor, más datos, técnicos…

    Topología de red

    Sistema operativo, IPs, rutas en los equipos con problemas.



  • Hola, a mi me pasó que bloqueaba la resolución DNS pero si hacía ping al exterior, y hasta que descubrí el por qué…
    Comprueba si el fichero de configuración del cliente tiene esta opción:

    setenv opt block-outside-dns
    

    Si es así, quítala porque esto bloquea la resolución DNS al exterior cuando está conectada la VPN.



  • donde veo esa opcion en el programa?



  • ¿Utilizas el Client Exporter para OpenVPN?, porque si lo configuras manualmente entonces es posible que sea por otra cosa.

    También comprueba si has puesto para que todo el tráfico pase a través de tu VPN. Si lo quieres hacer así tienes que configurar también el Firewall para redirigirlo al exterior.
    Eso lo puedes hacer ejecutando el comando "route print" estando conectado a la VPN, y ahí te saldrá una entrada 0.0.0.0 con máscara de red 0.0.0.0 y te dirá por qué puerta de enlace sale.

    Un saludo.


Log in to reply