Cannot have LAN+WAN at same time 2.3.2-p1



  • Hello,

    I'm currently using a Lenovo T43 laptop without any problems, but I'm trying to setup pfSense on my Acer Aspire One and Lenovo X200.
    I'm using the build in ethernet port on both for LAN, and a external USB adapter for WAN.

    The problem is, that only one interface works at the time. If I have a cable plugged into the WAN port, I will only get and IP on WAN, and the static LAN ip adresse won't show up.
    This seems really weird, sine the LAN IP is static..
    Could anybody help me out? It happens on a clean install of pfSense and after I update it to -p1.

    The WAN I'm trying to use to test, is currently my own LAN network, which should be fine since it just uses a DHCP LAN adress as WAN (done it loads of times before).

    Hope somebody can help me!

    (happens on full install and nano install)



  • What exactly happens when you plug in the WAN? Can you not ping the LAN interface from a machine plugged into LAN? Are there errors on the console or in the logs? I would venture to guess that your problem is due to the USB nic. My advice is to trade one of your laptops for an old desktop, put a second nic card in that and try again without a usb nic in the mix.



  • The problem doesn't occur as  I plug it in, it occurs if the WAN is connected. The USB nic still gets a WAN IP address, but the LAN will not work.
    The samme happens if I switch around, and use the build in as WAN, and the USB nic as LAN.

    It's a really weird problem. I've tried with the following two adapters
    AX88772B
    AX88178

    So I don't see why it would be the USB nic, since it picks up an IP fine, and can be seen by the system without any problems.

    EDIT: And yes, I cannot ping the LAN network when the error occurs. If I eg. unplug the WAN ethernet cable, after some time I can ping LAN again, but if I plug in the ethernet cable again, then after some time it will not work again.

    EDIT2: Could it be because the WAN address is in the same subnet as the LAN address? Seems weird seems it has worked before.



  • Your 'WAN' doesn't happen to be in the same subnet as your LAN does it? (e.g. 192.168.1.x)
    If you have the same subnet on both sides, yes, you will break the firewall because it won't know which interface to use. If this is the case, change the LAN to a different subnet.



  • Yeah it does, the WAN is something like 192.168.1.146. But seems weird, because I think I remember that it has worked before? But hell, I might remember wrong..

    Thanks I'll try it asap and report back!

    EDIT: works now!


Log in to reply