SG-2440 ignores PuTTY keyboard input



  • I'm new to pfSense / SG-2440 and I've searched the topics but not found this issue.

    Setup:

    • New SG-2440, fresh hardware reset, WebGUI works, the box seems fine.
    • Dell XPS (Win10) with PuTTY install, pfSense 'USB' com cable connection all appears fine
    • Both Port and PuTTY set to: COM3, 115200, 8-bit, noParity, 1-Stop, XonXoff
    • When PuTTY console window up, can watch text of SG-2440 boot process. Boot completes.
    • Additionally, I do not see a "list of actions" I would expect to see, coming from the SG-2440; just 'boot done'
    • Changing the baud rate to 9600 (COM3, PuTTY and SG-2440 to match) did not help; so not speed related
    • Tried all sequences several times … just in case ... always the same symptom

    Problem: SG-2440 ignores (no response or echo) all keyboard entry (CtlC, Rtn, ABC..., dead)

    • I see no other config setting to change and see nothing in the boot log that seems associated.
    • Setting PuTTY 'Force local echo' does echo keystrokes to the window, but no CR/LF (as expected)
    • Still no response from the SG-2440.

    While it still might be a config issue, is it plausible the box/cable is at fault?

    Thanks in advance for any suggestions.


  • LAYER 8 Netgate

    Can you connect a device to LAN, get a DHCP lease, and log into https://192.168.1.1/ using admin/pfsense?



  • Thanks for the reply! If I understand your intent, yes, access to the GUI through the LAN port at the default 192.168.1.1 does work.

    Additional observations:
    I swapped cables, then tried "interfering" with the boot sequence. It now appears that the cable is fine and the console interface does exchange data; it's just the odd state of "no interaction" via the console interface at the end of boot sequence when the "Bootup complete" appears. I can't get the box's attention; not even CR.

    However, if I interrupt the boot process, I can select boot options, boot to 'single user' mode and then use bash to look at the disk files. So, I was mistaken that Putty or the cable wasn't working.

    However, I should have an "active" interface with a FreeBSD command menu after boot; Right? Since I don't, how do I start that interface and where do I look to learn why it does not start by default? I don't see a choice in the the GUI.

    Thanks!


  • LAYER 8 Netgate

    There are some instances where the /etc/ttys file gets clobbered, resulting in no console. It sounds like you are experiencing this.

    Just plug in your WAN to your existing LAN so it gets a DHCP address, DNS servers, and internet access through your existing connection.

    Then upgrade to the latest version in System > Update.

    If that doesn't fix it, navigate to Diagnostics > Command prompt and execute this command:
    pkg upgrade -fy pfSense-base

    Then either reboot or execute the following command:

    kill -HUP 1

    And your serial console should be functional.



  • [SOLVED]

    The system is new, but I checked via the System Update.  Showed 2.3.2_1 Up to Date.
    So used the GUI exec command interface to do the pkg update and that fixed it.
    The BSD command list popped up in the console window as intended.

    So, very accurate diagnosis! Thank You!


Log in to reply