SG-2440 no WebGUI with new LAN IP



  • With the hardware, GUI and console up, my first requirement is to change the LAN IP. I'd thought this to be just a simple address change from the default 192.168.x.x to 172.28.x.x – but that didn't work.

    Setup:

    • SG-2440, assume factory defaults with working WebGUI and working console
    • PC browse URL: 192.168.1.1  does bring up the WebGUI

    LAN test config:

    • Change LAN IP via WebGUI
    • LAN IP: 172.28.1.1 /24
    • Mask: 255.255.255.0
    • Save settings but Hold off 'Apply Changes'
    • Enable DHCP, Range: 172.28.1.10 -to- 172.28.1.20
    • Save settings, then go back and Apply Changes

    Win10 PC:

    • With PC still wired LAN connected to SG-2440 LAN port
    • IPv4: 172.28.1.50 (Static IP address)
    • Mask: 255.255.255.0
    • DNS: 172.28.1.1
    • Browser URL: 172.28.1.1
      Fails to connect to WebGUI
      Reboot SG-2440 does not help.

    Win10 PC:

    • So, set IPv4 / DNS to DHCP
    • Browse URL: 172.28.1.1
      Still fails to connect to WebGUI
    • Browse URL: 172.28.1.1/:80 (Fails)

    Console:
    #ping 172.28.1.1 (Works)
    #ping 172.28.1.50 (Fails)
    #ping 172.28.1.15 (Fails)
    #sockstat | grep lighttpd
    Shows no listing -- so no reference to port :80

    So, I assume I must be missing, overlooking or misunderstanding something basic.
    Thanks in advance for any suggestions.



  • hi

    does win10 pc receive ip via dhcp ?

    cheers
    chris



  • Yes, the default 192.168.1.1 LAN config w/DHCP does work. The LAN connect fails with the new 172.28.1.1 IP, with or without the DHCP server and the PC using either DHCP or static IP addressing.

    I keep expecting to find some other setting to re-config with the IP change but, then again, I don't think I should need to set anything other than LAN IP, DHCP, Mask and DHCP IP Range.


  • LAYER 8 Netgate

    Double-check everything (netmasks(!)).

    I've done the same thing robably 500 times. it works exactly as you would expect.



  • Funny you should write that …

    • Again, just did a box reset to default, then dropped the DHCP to use Static on the 192.168.x.x default
    • Verified PC static at .1.16 via the ARP table ... that worked ...
    • Then switched over to 172.28.1.1 LAN ... and static 172.28.1.16 PC
    • It worked ... and ARP table agrees.

    Must have been my 501st try ;-)
    Thanks for the use of your magic wand.


Log in to reply