Lentidão em acesso interno



  • Bom dia a todos da comunidade.
    Andei lendo vários tópicos, mas não consegui encontrar uma solução para meu problema de lentidão em acesso interno, vou explicar minha infra:
    Modem -> pfsense com squid+squidguard -> rede com AD e proxy apontando pro pfsense via GPO.
    O que me acontece é que na minha rede, tenho um aplicativo de imagens DICOM (raio x) e esse acesso é via http, o sistema baixa um arquivo jnlp, nesse arquivo tem o endereço do servidor local: 192.168.x.x:8585/weasis/….
    O problema é que para iniciar a aplicação, meu sistema fica uns 3 minutos "verificando a aplicação" ou então "fazendo download da aplicação". Sem o proxy funciona normal.
    No squid eu já coloquei a porta 8585 nas ACL, até criei uma regra no firewall -> rules, para aceitar todo trafego na porta 8585.
    E é claro, que também adicionei o ip do servidor local no squidguard. Alguém teria mais uma dica onde eu poderia verificar o porque dessa lentidão?

    ps: mesmo com o squidguard desativado e sem regras de bloqueio, a lentidão acontece.



  • Pelo que você falou, que o proxy é imposto via GPO, concluo que seu proxy não seja transparente.
    Tente o seguinte: modifique sua GPO, informando que os acesso WEB com destino a servidores da rede interna (192.168.x.x) não serão enviados ao proxy (isto pode ser feito manualmente nas configurações do browsers, mas via GPO é mais fácil).



  • Bom dia Fernando, obrigado pela resposta.
    Eu configurei na minha GPO:

    Não usar servidores proxy para endereços iniciados por http://192.168.x.xy:8585;http://192.168.x.xy;192.168.x.xy;192.168.x.xy:80;

    Mas aparentemente não surte efeito.
    Adicionei manualmente nas preferências de rede do java, para não utilizar proxy para endereços começados por…. e mesmo assim não surtiu efeito. Por isso queria ver se existe alguma coisa que eu faça diretamente no proxy.



  • Existe, mas apenas quando o proxy está em modo transparente.

    Você chegou a verificar se a GPO está colocando suas exceções?
    Uma vez as exceções determinadas, ao acompanhar os LOGS do SQUID, os hosts em questão ainda aparecem no LOG?



  • Bom dia, cara coloca o endereço do teu servidor no Bypass do Squid, em endereços de entrada e saída e verifica se funciona.
    Se o problema está no acesso dos clients no server, coloque um Bypass para que o Proxy não verifique as conexões ao servidor.



  • @fernandofolha:

    Existe, mas apenas quando o proxy está em modo transparente.

    Você chegou a verificar se a GPO está colocando suas exceções?
    Uma vez as exceções determinadas, ao acompanhar os LOGS do SQUID, os hosts em questão ainda aparecem no LOG?

    A GPO está correta, fiz uns testes e ela realmente está lá no navegador. Não pensei em analisar os log's do Squid antes (não sei porque).



  • @hunterjn:

    Bom dia, cara coloca o endereço do teu servidor no Bypass do Squid, em endereços de entrada e saída e verifica se funciona.
    Se o problema está no acesso dos clients no server, coloque um Bypass para que o Proxy não verifique as conexões ao servidor.

    Bypass é só no modo transparente mesmo. Mas modo transparente pra mim fica fora de questão por causa dos bloqueios https.



  • Mas bloqueio HTTPS pode ser feito tranquilamente no Proxy transparente, se for somente este o caso.



  • Esse "tranquilamente" envolve certificados? Eu tentei utilizar o modo transparente, com certificados instalados, mas meu problema se dava ao acessar sites liberados, por exemplo, digitava https://bancodobrasil.com.br ele redirecionava para https://200.xxx.xxx.xxx (no caso o ip do site) e voltava a pagina do squidguard dizendo que o site http://200.xxxx não era permitido o acesso. (trabalho com listra branca aqui na empresa).



  • Sim Rodrigo, tenho em vários clientes, incluindo contabilidades, que utilizam o Proxy transparente e certificados digitais. É só questão de configurações mesmo.


Log in to reply