Pfsense behind Fritzbox 6490 –> Fritzbox crashes



  • Hello,

    i want to use a scope7 pfsense appliance behind a Fritzbox 6490 (double NAT, no bridge mode).
    I am currently running exactly the same setup just with an Asus AC68U behind a Fritzbox 6490 and everything runs fine.

    As soon as i replace the Asus Router with the pfsense appliance i get trouble.

    Everything runs smooth as long as only a few clients are online but with higher load (maybe >10 clients so not really much) the fritzbox gets very slow and reboots after 5 minutes.
    The problem is not the traffic alone because 2-3 clients doing speed tests runs fine.

    Any ideas whats going on or where i could look for a solution?

    Thank you and best regards,

    John



  • As it's the Fritzbox that's failing, have you checked the logs (if any)? Can you port any syslog data from it to a server for analysis?



  • Just a guess - I'm thinking of possible limit of NAT State table size on Fritz.



  • Fritzbox has no logs after reboot and i cannot access the interface or telnet as soon as the problems start.

    Regarding NAT table size:
    Why does it happen only with pfsense and not with the asus router?
    Using the fritzbox directly without any additional router works fine too so it is something in the pfsense config that makes the fritzbox unstable.



  • @jonnyD:

    Fritzbox has no logs after reboot and i cannot access the interface or telnet as soon as the problems start.
    Using the fritzbox directly without any additional router works fine too so it is something in the pfsense config that makes the fritzbox unstable.

    If you're running something which has no way of providing any troubleshooting information, then I'd get a better solution.
    The fact that you can't seem to pick up any logging from the device which is crashing strikes me as a more obvious issue than what you're actually connecting to it. PFsense runs on it's own without any issues and shouldn't create any problems for a standard router - it doesn't for mine.

    On the subject of Fritzbox (the name says it all, really), I've Googled and found the following link:

    https://ask.wireshark.org/questions/8541/how-can-i-capture-traffic-with-a-fritz-box

    I believe you should be able to log to a syslog server from a FB device, based on the brief bit of Googling I've done. If you try using Google yourself you may find some answers.



  • Hi Jonny,

    did you find any solution. I ran into the same problem. I don't find a cause but sometimes my cable provider fritzbox6490 "crashes" when i am using my PCs. For no reason my wan connection stops working. The first indicator is higher pings and/or direct timeouts on 8.8.8.8, at  this point without doing something the fritz crashes within a few minutes.

    6490 with Fritz 6.5 (bridge mode)
    APU2C4 pfsense 2.3.4 (static wan ip)

    mostly this issue happened when i was logging into an fresh bootet System (MacOS/Debian/Ubuntu/WIN7/WIN10).
    First i thought dropbox sync was causing this, but it happened also on systems without dropbox.

    When using my Cisco ASA5506 there is no problem. i tried several reinstallaions and different system configurations.

    kind regards
    ralto