2.3.2 clean install failed with "Updating pfSense-core repository catalogue…"



  • I have upgraded from 2.2.6 on vmware and running pfblocker, snort and squid without any problems. Exported and saved the settings.

    I also did a clean install of 2.3.2.  It installs fine but when I try to import the settings, it reboots and hangs here:

    "Updating pfSense-core repository catalogue…"  Eventually it fails.

    Any ideas?



  • I had the issue multiple times in my test envoinment.
    pfsense try to connect to repository to update but could not connect to server.
    Check your WAN interface if your settings are correct , may be after restore you are sure the NIC assignments are the same in the config that they were before

    • The solutions for me was to break error message with ctrl+x
    • copy the config.xml file from /cf/conf/backup/config-0.xml to /cf/conf/config.xml
    • detele the config tmp file in /tmp/config*
    • reboot the pfsense

    and re assign the interfaces and ip correctly



  • My upgrade was getting stuck the same way. The errors pointed to the custom options in unbound.
    I commented out the option - server:include: /var/unbound/pfb_dnsbl.conf  in DNS resolver. Simply put a # in front of the line and save.
    To double check I went to line #98 if I remember right at /var/unbound/unbound.conf.
    Upgrade worked fine with repository update and finished. After completion I removed the # sign in front of the option. Double check the unbound.conf file to make sure comment out is removed.
    Worked for me. Not sure if others may have similar problem. Mine was for 2.3.3 upgrade on spinning rust.


Log in to reply