Upgraded SG-4860 Failed; Boot up Stalls



  • Upgraded my SG-4860 to 2.3.2 and then uploaded the config from a 2.2.6 working pfSense and this is all I'm getting:

    USB MSC vendor='Generic' product='Ultra HS-COMBO' rev='1.98' type=0 removable=1
    USB MSC blksize=512 sectors=7733248
    Initialized USB HUB (1 ports used)
    All threads complete.
    Scan for option roms
    Running option rom at c000:0003
    pmm call arg1=1
    pmm call arg1=0
    pmm call arg1=1
    pmm call arg1=0
    Running option rom at c100:0003
    pmm call arg1=1
    pmm call arg1=1
    Running option rom at c200:0003
    pmm call arg1=1
    pmm call arg1=1
    Running option rom at c300:0003
    pmm call arg1=1
    pmm call arg1=1
    Searching bootorder for: /pci@i0cf8/*@14
    Searching bootorder for: /pci@i0cf8/*@14,1
    Searching bootorder for: /pci@i0cf8/*@14,2
    Searching bootorder for: /pci@i0cf8/*@14,3
    
    Press F12 for boot menu.
    
    Select boot device:
    
    1\. USB MSC Drive Generic Ultra HS-COMBO 1.98
    2\. iPXE (PCI 00:14.0)
    3\. iPXE (PCI 00:14.1)
    4\. iPXE (PCI 00:14.2)
    5\. iPXE (PCI 00:14.3)
    
    Searching bootorder for: HALT
    drive 0x000f5890: PCHS=0/0/0 translation=lba LCHS=958/128/63 s=7733248
    Space available for UMB: c4000-f0000, f0000-f5890
    Returned 253952 bytes of ZoneHigh
    e820 map has 8 items:
      0: 0000000000000000 - 000000000009e800 = 1 RAM
      1: 000000000009e800 - 00000000000a0000 = 2 RESERVED
      2: 00000000000f0000 - 0000000000100000 = 2 RESERVED
      3: 0000000000100000 - 000000007fbde000 = 1 RAM
      4: 000000007fbde000 - 000000007fe00000 = 2 RESERVED
      5: 00000000e0000000 - 00000000f0000000 = 2 RESERVED
      6: 00000000fee00000 - 00000000fee01000 = 2 RESERVED
      7: 0000000100000000 - 0000000280000000 = 1 RAM
    enter handle_19:
      NULL
    Booting from Hard Disk...
    Booting from 0000:7c00
    
    

    Tried pushing the hardware reset button and got nothing.

    Any thoughts?


  • LAYER 8 Netgate

    What kind of hardware was the 2.2.6 config from?



  • A actual server (couple procs, 8 gigs, dual drives).


  • LAYER 8 Netgate

    It is probably set to VGA console instead of serial then. Seems you should see more output before it switches though.

    How did you do the upgrade? Did it work fine after the upgrade but before the configuration restore?



  • I"m not confident with the VGA/Serial idea only because I've seen it up to that point before and it's just not loading the OS

    I upgraded via the console and from what I can tell the upgrade went fine actually.  I reset the device to factory defaults, plugged it into our network for internet access and performed the upgrade.

    After that I imported the config.  It did complain about the interface mismatch (em1, em2, etc).  I tried to change the interfaces and the vlans but it didn't like it.  It rebooted anyway, asked me to assign the interfaces and when it was done they were all messed up.

    I reset to defaults settings 4 times trying different ways to correct the interface mismatch and after the 4th reboot is when it was caught in a loop.  It would stall for about for a number of mins, then start over again until now it just stops and shows what I posted.



  • Try loading 2.3.2 fresh again, but edit the config before restoring. Change the interfaces to match the SG-4860. If it's outputting to serial, there should be an <enableserial>under system in the config.</enableserial>



  • How will the VLANs be converted?  Simply a swap of em# -> igb#?



  • Yeah, I search and replace with a text editor. Switching interfaces with lots of vlans isn't handled well by the mismatch/assign logic.


  • LAYER 8 Netgate

    Yeah. Just be sure you approve every change. Don't want to do a blanket replacement of, say, re3 and clobber things like <linkshare3>or an re3 in some base64 somewhere.

    I think the actual interface names are only at the top in the interface definitions, and in the definitions for VLANs and laggs. Everything else is "relational" to those places.</linkshare3>



  • I'll look it over again but I tried that and it didn't work.  I'm starting to believe that the OS is just hosed.



  • I just went thru this myself, upgrading an old Lanner FW-7535 running 2.1 to a new XG-2758 running 2.3.2.  I figured the safest way to do it was to manually edit the config to be sure.  I spent about 20 minutes carefully searching & replacing interfaces and names by hand and then imported the new config. Worked perfectly and everything came up roses.  The new XG is running great so far.



  • That is good to hear.  Now I just need to reinstall pfSense and I'll give that a go.

    Thank you all for your comments and suggestions!!


Log in to reply