Troubleshoot sg2440 keeps going offline?



  • A few months ago I bought a SG-2440, it's been working well.

    About a week ago it started taking the WAN offline.
    I thought it may be my ISP, Charter cable, but I no longer think that is the problem.
    When it is offline, as expected, I can ping the LAN devices, including SG-2440.
    Sometimes it comes back online after a few minutes of waiting.
    I've discovered that from status->interface, I can release the dhcp on the WAN (igb0) and wait 10 seconds and renew.  Usually that fixes it but not always.

    Restarting the cable modem usually fixes it.
    Rebooting SG-2440 usually fixes it.
    cycling power on my switch has not seemed to make a difference.

    The cable modem has status lights and when this problem exists the status lights show the modem is connected.  This has caused me to wonder if it's the igb0.

    I forgot to check the igb0 link light and will do so next time it goes offline.
    Is there anything in a log file that I can look for to give a clue?
    Are there any other troubleshooting tips?



  • Further the above message, when I lose igb0 goes offline this is a typical entry in the System Log:

    Nov 4 18:08:11 kernel arpresolve: can't allocate llinfo for <wan ip="" addr="">on igb0

    This message repeats about every 30 seconds.
    Any idea what may cause this error message?</wan>



  • I can't be sure but from what you've described it sounds like your Charter modem is losing sync from time to time and reverting the DHCP that it's "passing through" to your pfSense router to a temporary subnet.  This is a known behavior especially for cable modems and it can be very annoying.

    It would be great it pfSense/FreeBSD handled this "bug" a little better but there is a possible workaround that you can try…

    Try going into your WAN Interface settings and under "Reject Leases From" put 192.168.100.1
    See if that makes any difference...

    Here are some references:
    https://forum.pfsense.org/index.php?topic=63474.0
    https://forum.pfsense.org/index.php?topic=62964.0



  • @luckman212:

    I can't be sure but from what you've described it sounds like your Charter modem is losing sync from time to time and reverting the DHCP that it's "passing through" to your pfSense router to a temporary subnet.  This is a known behavior especially for cable modems and it can be very annoying.

    It would be great it pfSense/FreeBSD handled this "bug" a little better but there is a possible workaround that you can try…

    Try going into your WAN Interface settings and under "Reject Leases From" put 192.168.100.1
    See if that makes any difference...

    Thanks for this tip, I'll give it a shot.  And also thanks for the references.

    In my post, <wan ip="">refers to the dhcp IP assigned by Charter cable, not to 192.168.100.1.  One of the references you linked mentioned accessing 192.168.100.1.  I usually can ping that address when the WAN is 'offline', I guess that makes sense.  Unfortunately, I have to access to the internals on that modem, all I can get at that address is signal levels.

    For reference, my modem is a Cisco 3208 DOCSIS 3 with no wireless.  I do not use a cable phone so it provides only internet to pfSense.</wan>


Log in to reply