PfSense 2.2.6 using Squid + LightSquid don't report user name.



  • Hello all.

    I'm new using pfSense and I'm a little confised with that. I just set the squid been not transparent proxy, ask for user (local user). When I try to access the Internet the window is show to me pass a user and password. Everythin works fine but when I go to LightSquid it not reports me the access with name of the user, just IP address. Trying to see if the the problem is show in any log I let one termial running "tail -f /var/squid/access.log" and I can see the name of the user whith I'm passing. The place wher I add the user was: Services-> Squid General Settings -> Users" and set the authentication to local. How I saed the authentication is working the problem is that my reporting is just showing the ip address not the name of the user.
    What am I doing woring? Where can I fix this?

    Best regards.



  • What is IP Resolve Method set to in Lightsquid's config?



  • Hello KOM

    The method is DNS.

    May I change? If yes to what?

    Best regards.



  • May I change? If yes to what?

    Well, read the list of options to see which one suits you best.

    Does reverse lookup work on your network for those IP addresses?  Are these IP addresses registered in DNS?  DNS should work for you, as should Demo and Simple.  Try them yourself and see.  Change it, Save then Refresh to update today's report.



  • Hello KOM.
    Thanks very mutch. When I change to DEMO works fine. Thanks a lot.

    Best regards.


Log in to reply