Traffic Shaper interface does not work - 2.3.2-release-p1



  • Hello Everyone,

    I'm running 2.3.2-RELASSE-p1 (amd64) on APU router board. I've realized that Traffic Shaper user interface does not work. I had an old traffic shaper configuration from the previous pfSense version (2.2.x), and after upgrade I've realized that shaper configuration cannot be modified. I removed the configuration in order to create the new one, but now I can't use wizard or manually create shaper rules.

    While running the wizard, I'm getting the message: "There are less interfaces than number of connections!". If I try to manually create the rule, after "saving" the changes, web interface will refresh, and new rule will not appear on the list. My system has two WAN interfaces (DHCP based), and one LAN interface.

    Do you have any suggestions? Traffic shaping is essential to me to handle the VOIP traffic.

    Thank you in advance,

    Alex



  • Maybe reset to defaults then restore individual sections of the config to see which section is causing problems?



  • Thank you for good suggestion. Before I disassemble everything, is there any debug log which could help me pinpoint what is blocking the traffic shaper configuration?

    Regards,

    Alex



  • I've got it… In the Interfaces->LAN configuration page, I have configured the static IPv6 address. Once that address is removed from the configuration, traffic shaper interface works again. I don't know if this is a bug, or a feature. If traffic shaper does not work with IPv6, it would be good idea to leave the message in the GUI instead of the silent failure.

    Regards,

    Alex


Log in to reply