NTP PPS Jitter Question



  • I have had added NTP service on 2.3.2-RELEASE-p1 a couple of weeks ago and after tweaking the settings I believe I have everything working correctly.
    I now have a GPS receiver interfaced with the firewall that outputs NMEA data as well as a 1PPS signal on pin 1 (DCD) of the DB9 RS232 connector.

    • My question is how much PPS Jitter is acceptable ?
    • How does PFSense determine jitter range ?
    • What is the pulse width PFS likes to see ?

    Every hour or two I am seeing this type of message in the NTP Log
    Nov 5 13:55:26 ntpd 99094 kernel reports TIME_ERROR: 0x2307: PPS Time Sync wanted but PPS Jitter exceeded

    There is plenty of info on GPS jitter available but not much info on how PFSense handles GPS data.
    The PFS doc is very light on NTP service and especially regarding GPS data.

    Lee



  • Did you find out of this?
    I just connected a gps to my firewall (Garmin gps 18 lvc) and I get the exact same error. Nothing at first, but now several messages per hour.



  • It's been a while but I think the problem is you have to turn PPS Serial port to NONE under the PPS tab.

    What happens is the server gets the PPS signal from the Serial port (forgot the pin number).
    It appears the PPS tab is if you are using either only PPS or is getting that from a different port than the GPS.

    My assumptions might not be exactly correct but it did fix the problem and I am still getting PPS signal from the Garmin via the serial port.

    Lee



  • Thanks for your reply (and sorry for my late one)
    I checked my settings, and the PPS was disabled under the PPS tab.

    What I've tried now is a clean install of pfSense 2.3.3.
    I've disabled all power saving (c-states etc.) on the router.
    I've updated the BIOS.
    I've checked that I have the latest firmware on my gps.
    I've changed the gps to 9600 baud, and only RMC and GGA sentences. (200ms pps pulse)
    edit
    I forgot to add, I've changed the GPS initialization sentences to only "$PGRMC,,,,,,,,,,,,,*67".
    pfSense doesn't seem to allow this box to be empty (it automatically gets refilled with the defaults if I try), so I use this sentence so as to not change the settings in the gps.

    All of this seems to have helped. At most I get 5x "29318 kernel reports TIME_ERROR: 0x2307: PPS Time Sync wanted but PPS Jitter exceeded" messages per hour. usually around 3 now.

    I'm running out of things to try.
    The next thing I'm considering is trying to enable falling edge PPS signal processing. in case the signal is inverted in my computer.
    After that I'm thinking of de-soldering the LED connected to the DCD line in the serial connector, although it seems many people on the web have this LED without any issues!



  • Ok, Enabling falling edge PPS signal processing was definitely NOT the solution!
    After having tried it for a day it was obvious it made things much worse.

    I might try to de-solder the led on the connector later on.


Log in to reply