Question on Config/VM Networking setup

  • Hello, and thanks in advance for any assistance.

    I have the following setup
    Im running Windows 7 x64, Vmware Workstation

    WAN - Vmware setting=NAT <em0>on PFsense (DHCP) @ .180 Addr space
    LAN- Vmware setting=Host Only <em1>on PFSense @ .179 addr space (static assigned clients)
    OPT1- Vmware setting=Host Only <em2>on PFSense @ .178 space (Static assigned clients)

    My clients cant get to the internet, no idea why. I had this working in a hotel, plugged in and had to change some address subnets around, and has not worked since. I thought DNS played a role in my issue, just not sure what piece is not configured right.

    From my PFSense WebUI I tested Ping, and DNS Lookup. Both work perfectly.
    All up and running with below address
    WAN 1000baseT <full-duplex>
    LAN 1000baseT <full-duplex>
    OPT1 1000baseT <full-duplex>

    Just did a update to

    From my clients in the 179/178 (No clients on 180 as its reserved for my Vmware NAT adapter) I can ping each other, no issues, ping by FQ/DNS doesn't work

    The firewall has open any * as seen below to test any rules causing issues

    For the vmware side I have the following setup as seen in image
    VMnet1 - clients
    VMnet2- Clients
    VMnet3- NAT DHCP where PFSense VM sits

    Also seen are my rules, nothing I can see causing this

    When I change the NIC on my VMs from one of the host only- to the NAT one (Vmnet3) I can get ouyt, this tells me its not the adapter config, and potentially the PFSense machine..

    Is my DNS screwed up, if so, what do I need to do. I have tried using the DG as the DNS, many other options and nothing is working

    And just now I cant even get to the PFSense URL.

    Any help is appreciated, big time..

    Gone through all sorts of topics, including this one


  • I usually use a custom network (VMnet2-7) for LAN, OPT1 etc.  Works like a charm.

  • gone through all that, and the VMNet adapters
    still not getting anywhere
    any other ideas

    at this point ill throw $10 to a PayPal account ,,seriously

  • Any help is greatly appreciated

    I can ping now from VM to VM and DG from hosts, but now the PFSense web interface wont even come up.
    No idea what is going on, even if it was DNS, IP for web UI should come up.. >:(

  • The way I normally do it that works every time and makes sense from a networking perspective:

    WAN - Bridged (to your real LAN network)
    LAN - Custom: VMnet2
    OPT1 - Custom: VMnet3

    For your virtual LAN clients, make sure their NIC is also on Custom - VMnet2.  Your DMZ virtual servers go on Custom - VMnet3.

    Set pfSense WAN to get a DHCP address or set it manually.  Set LAN to some other private network space outside of your real LAN.  Enable DHCP on LAN and give it a range.  Your virtual LAN clients should have no trouble getting to the WebGUI.

Log in to reply