Unable to set time, get error "can't reach time daemon, time set locally"



  • I've tried using just the webgui to execute the date command, and also using SSH under root and get the same message.

    in SSH, it says setting local time… however, the system time does not change.

    time zone is configured correctly...  NTP would "appear" to be right; however, the time is consistantly 15 minutes off....  :(

    any ideas?



  • well.. it appears that since this is running in a VM, the system time is forced down from Hyper-V some how… the host had the wrong time settings (and was not configured to use an NTP server)... so ya, that was my bad.


  • LAYER 8 Global Moderator

    what time zone are you in?  What does your ntp status show for who your syncing with, and what is the offset, etc.  Can you post up screenshot of your ntp status.

    from ssh you can do a ntpq pe or and rv and get info can you post yours.

    For example here is mine

    
    [2.3.2-RELEASE][root@pfsense.local.lan]/root: ntpq
    ntpq> pe
         remote           refid      st t when poll reach   delay   offset  jitter
    ==============================================================================
    *pi3-ntp.local.l .PPS.            1 u  101  512  377    0.444   -0.088   0.042
    +esxi.local.lan  192.168.9.32     2 u  456  512  377    0.903   -4.088   0.155
    ntpq> rv
    associd=0 status=0615 leap_none, sync_ntp, 1 event, clock_sync,
    version="ntpd 4.2.8p8@1.3265-o Fri Jun 10 15:40:53 UTC 2016 (1)",
    processor="amd64", system="FreeBSD/10.3-RELEASE-p9", leap=00, stratum=2,
    precision=-18, rootdelay=0.444, rootdisp=28.649, refid=192.168.9.32,
    reftime=dbcdf7aa.4bf9d853  Wed, Nov  9 2016 13:29:46.296,
    clock=dbcdfc10.e76acc80  Wed, Nov  9 2016 13:48:32.903, peer=39307, tc=9,
    mintc=3, offset=-0.088246, frequency=-55.135, sys_jitter=0.041148,
    clk_jitter=0.094, clk_wander=0.016
    ntpq>
    
    


  • hey johnpoz,

    I'm in CST, here:

    ntpq> pe
        remote          refid      st t when poll reach  delay  offset  jitter

    a1.pcloud.com  .STEP.          16 u  18h  512    0    0.000    0.000  0.000
    *104.156.99.226  204.123.2.72    2 u  511  512  377  78.649  -0.460  0.928
    ntpq> rv
    associd=0 status=0618 leap_none, sync_ntp, 1 event, no_sys_peer,
    version="ntpd 4.2.8p8@1.3265-o Tue Jul 19 16:25:02 UTC 2016 (1)",
    processor="amd64", system="FreeBSD/10.3-RELEASE-p5", leap=00, stratum=3,
    precision=-20, rootdelay=97.774, rootdisp=57.067, refid=104.156.99.226,
    reftime=dbcef9cc.d7702e52  Thu, Nov 10 2016  7:51:08.841,
    clock=dbcefae3.910118a5  Thu, Nov 10 2016  7:55:47.566, peer=40658, tc=9,
    mintc=3, offset=-1.678046, frequency=-45.383, sys_jitter=0.000000,
    clk_jitter=0.782, clk_wander=0.077

    In hyper-v integration services, if "time synchronization" is enabled for the VM, I guess you get the error noted in my post.

    after disabling it, i was able to change the time without an issue.


  • LAYER 8 Global Moderator

    ah great.. have you checked after that post that your able to talk to a1.pcloud.com ?  Your reach on all ntp servers you have set should be 377 after been running for a while.  If it never goes to that or can not maintain 377 then you have a problem talking to the ntp server, or it has issues and should pick a different one, etc.

    So if you were setting time from your host, and it was off you prob want to look to how your host is setting its own time.



  • the host was not setup to use anything.. which is a problem, but also I have no clue where it's getting the a1.pcloud.com.  Does pfsense use it's own NTP settings?

    [EDIT]

    actually, in this situation i have to laugh at myself cause it was obviously getting the time for the VM from the host machine… well, that is when it was configured to sync it.


Log in to reply