Squid (or lightsquid) stops working 1st day of each month?



  • i have pfSense 1.2,
    squid 2.6.18.1_05, - updated recently but no change to this issue
    lightsquid 1.7.1

    the only other package i have is bandwidthd 2.0.1.1

    it seems every first day of a new month squid, or at least lightsquid stops working, and no entries are found by generating reports. this has happened every month since i put together this pfSense machine. squid logs rotate weekly on mondays, and hitting refresh doesn't help, but reinstalling the packages solves the problem.

    does anyone know whats going wrong? i have already reinstalled the packages this month, so next month i will try just one or the other to narrow down which package is iffy. any help appreciated, thanks in advance



  • What settings "log rotate" you have (squid GUI & LS GUI) ?



  • thanks for replying

    for squid, i must have overlooked it when configuring it so it has been left blank (ie disabled)
    lightsquid is weekly monday

    you think squid's log not rotating is the problem?



  • I don't know .. but this is can be sheduler too.
    Aso what you have in /etc/crontab (i have pm and e-mail if so) ?



  • i have pm'd you my /etc/crontab, thanks for taking a look



  • I not found squid rotate options. This problem need look when this happen (permissions. crontab jobs. etc..). Possible tell me in next time? (ICQ, mail - pls look my profile)



  • sure thing. thanks for taking a look, see you in october :)



  • @sentofuno:

    sure thing. thanks for taking a look, see you in october :)

    A.. make october in you pfsense (better make 30 september and leave to night  ::) )



  • so sorry, i thought i was the last one to post. i didn't know you'd replied..

    well its november 1st and it seems to be ok now. whatever it is i did was after you suggesting it was to do with log rotation, so thank you you appear to have solved the problem.

    cheers


Log in to reply