Problem installing and upgrading packages version 2.3.2_1



  • I seem to be having real issues upgrading pfsense, packages and installing new packages.

    I first tried to install ntopng but I get:

    The process will require 78 MiB more space.
    4 MiB to be downloaded.
    Fetching freetype2-2.6.3.txz: …....... done
    Fetching libfontenc-1.1.3.txz: .. done
    Fetching fontconfig-2.11.1_2,1.txz: .......... done
    Failed

    pfblockerng:

    Installing pfSense-pkg-pfBlockerNG…
    Updating pfSense-core repository catalogue...
    Fetching meta.txz: . done
    Fetching packagesite.txz: . done
    Processing entries: . done
    pfSense-core repository update completed. 9 packages processed.
    Updating pfSense repository catalogue...
    pfSense repository is up-to-date.
    The following 5 package(s) will be affected (of 0 checked):

    New packages to be INSTALLED:
    pfSense-pkg-pfBlockerNG: 2.1.1_4 [pfSense]
    whois: 5.1.5 [pfSense]
    lighttpd: 1.4.39_1 [pfSense]
    grepcidr: 2.0 [pfSense]
    aggregate: 1.6_1 [pfSense]

    Number of packages to be installed: 5

    The process will require 2 MiB more space.
    402 KiB to be downloaded.
    Fetching pfSense-pkg-pfBlockerNG-2.1.1_4.txz: …....... done
    Failed

    I was/am also having issues upgrading from 2.3.2 to 2.3.2_1. From the UI, where I see: (I have rebooted)


    I also tried using the console upgrade option, however, I get:

    Updating repositories metadata…
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue...
    Fetching packagesite.txz: .......... done
    Processing entries: .......... done
    pfSense repository update completed. 405 packages processed.
    pkg: Repository pfSense-core cannot be opened. 'pkg update' required
    pkg: Repository pfSense-core missing. 'pkg update' required

    Unlocking package pfSense-kernel-pfSense... done.
    The following 41 package(s) will be affected (of 0 checked):

    It then tells me I have 41 packages to be upgraded. However, when after selecting yes to upgrade, it downloads one or two - very very slowly - then fails. I tried this a few times but after downloading a few of the available updates it fails. I also tried with a forced upgrade.

    Is this some sort of mirror issue or something else?



  • Is this some sort of mirror issue or something else?

    Is the issue still happening?  If so, we'll need some more details and any diags you've already tried



  • @Jon:

    Is this some sort of mirror issue or something else?

    Is the issue still happening?  If so, we'll need some more details and any diags you've already tried

    It sees to be a connectivity issue, as it's intermittent and only seems to affect pfsense. The only oddity now are the version numbers, as shown in the images above, which is still happening.