Upgrage from 2.1.5 to 2.3.2 : IP Alias are gone…



  • Hy,

    I just change my old pfsense 2.1.5 for a new one with 2.3.2
    I restored my configuration from 2.1.5, everything is running fine.

    Except "IP Alias", i can't ping … I have a /29 and my WAN is in DHCP Mode.

    I try to delete "IP Alias" and create again, same result.

    I tried Proxy ARP / CARP, same result...

    What is wrong here ?

    Thanks

    Guldil



  • Another try today :

    • i remove all my IP Alias
    • i reboot everything this morning (Modem SDSL OVH and PFSENSE)
    • i create IP alias

    But it's the same, no icmp.



  • I just plugged my old pfsense 2.1.5 and IP alias are working again.
    So there is something broken in 2.3.2 :/



  • Not enough information to even begin.  What happens if yo upgrade, and then use the Backup/Restore function to restore just the aliases?


  • Rebel Alliance Global Moderator

    So with KOM not enough information to even to begin to guess what your problem is..

    For starters what is not working exactly?  You have some sort of alias setup.. What is in this alias, and in what rule are you using the alias that is not working?

    Sounds like you created a new pfsense with 2.3.2 and restored the config from 2.1.5 and did not actually go through a upgrade.  But you have a carp setup?  So multiple pfsense?



  • Since 3 years, i'm using an old Dell PC with pfsense 2.1.5

    On my WAN side, i'm using DHCP to get static IP from my ISP (OVH SDSL).
    I have a /29 IP with 3 IP activated on pfsense (just Virtual IPs > IP Alias in pfsense config, no CARP).
    These 3 IP are used for OpenVPN server

    I tried to move to another new hardware from LogicSupply, i just installed 2.3.2 on it and restore configuration from 2.1.5.
    Everything is working (Internet Access, routing, ipsec…) except the /29 block : can't connect on openvpn, no response on ICMP or traceroute.

    I plugged the old one, everything is ok, block /29 are back.

    It's a common setup except IP Alias / DHCP my be ?

    ![ip alias 2.1.5.PNG](/public/imported_attachments/1/ip alias 2.1.5.PNG)
    ![ip alias 2.1.5.PNG_thumb](/public/imported_attachments/1/ip alias 2.1.5.PNG_thumb)
    ![ip alias 2.1.5-2.PNG](/public/imported_attachments/1/ip alias 2.1.5-2.PNG)
    ![ip alias 2.1.5-2.PNG_thumb](/public/imported_attachments/1/ip alias 2.1.5-2.PNG_thumb)


  • Netgate

    "DHCP" together with "static /29" doesn't make a lot of sense.



  • @Derelict:

    "DHCP" together with "static /29" doesn't make a lot of sense.

    i know but it's working :)

    at start we used just one IP from WAN (DHCP config but always same IP).
    later i added /29 and everything worked well as expected.

    looks like 2.3.2, may be, don't like this setup…


  • Rebel Alliance Global Moderator

    If you have a static /29 from your isp.. Then set that..



  • @johnpoz:

    If you have a static /29 from your isp.. Then set that..

    No it's not so easy.

    With this ISP, you have one static IP obtained by DHCP on WAN side from a modem in bridge mode.
    Then you can buy /29 block and you can use them.

    I'll try to remove the DHCP from WAN, but if it's not working, i dont have solution except staying with 2.1.5 or stop using my extra /29 IP…


  • Netgate

    And the DHCP-assigned address is in the same /29 or is that an additional /29 routed to your DHCP address?



  • @Derelict:

    And the DHCP-assigned address is in the same /29 or is that an additional /29 routed to your DHCP address?

    Additionnal /29 routed directly to my WAN, with pfsense 2.1.5 i didn't have to put a gateway to use /29 like i have with other ISP.


  • Netgate

    What did you say?



  • Sorry, i'm not fluent in english.

    As i wrote, i don't know why extra IP (from /29) work with pfsense 2.1.5 and not in 2.3.2 (same configuration : /29 IP Alias in Virtual IP).
    I'll try these week to plug again 2.3.2 and remove DHCP.


  • Netgate

    What is the IP address, netmask, and gateway being assigned by DHCP?

    What are the IP addresses you are trying to assign to IP Alias VIPs?

    PM them if you want.