DHCPv6 server automaticaly enabled



  • I wasn't sure if this was the correct place to post this.

    By default it looks like the DHCPv6 service starts. If you add a nic to the pfsense box, after initially setting it up through the CLI. This causes an issue when you try to add your new interface as the lan interface. Upon assigning an ipv4 ip and applying the config, you get a warning telling you to assign an IPv6 IP as the DHCPv6 service is running. However when you go over to turn off the service, 'The DHCPv6 Server can only be enabled on interfaces configured with a static IPv6 address. This system has none.'

    Therefore, is it not better just to disable the DHCPv6 service in the default configuration, instead of using a temporary placeholder IPv6 IP and then disabling the DHCPv6 service and then going back and removing the placeholder address.

    Hope this made sense to some one :P


  • Rebel Alliance Global Moderator

    Huh??  I have setup pfsense many many times, going back lots of different versions and do not recall ever having such an issue.



  • Yea, weird. Just setup a completely new vm and got the same result

    Might be an issue if someone wasn't particularly comfortable setting the placeholder IP address I suppose

    I don't know if it's only an issue if you forget to assign two interfaces to the vm and then add the lan interface after setting the first interface up as wan
    Was using the vmxnet3 nic's if this makes a difference, latest firmware 2.3.2_1 (first thing I did after assigning wan was to upgrade the firmware)


  • Rebel Alliance Global Moderator

    Well I have never setup pfsense with just 1 wan interface, and then tried to go back and setup a lan, etc.  That would be a very one off sort of thing.. Normally when setting up pfsense you would be doing it from the lan side ;)



  • So is the DHCPv6 server always enabled by default on the LAN?

    I could see that causing issues with sites with windows servers performing DHCP already


  • Rebel Alliance Global Moderator

    no its not when you setup the lan..  Since you don't give it a ipv6 address, nor do I recall it being enable even when you setup ipv6 address until you turn it on.  I could fire up a vm and test it..



  • It was for me, I don't know if that's just an oddity because I added the nic after the initial configuration or if this just happens by default when you add an IPv6 address to the interface

    I feel that it would be better if it was off by default regardless, assuming my situation wasn't too weird lol