DHCP Server can't be enabled?



  • When I got to the Server>DHCP Server config page, I get the following error:

    The DHCP Server can only be enabled on interfaces configured with static IP addresses. Your interface is not configured with a static IP.

    I'm using a Soekris 5501-70, no wireless, pfSense-20080910-0258.img.gz, the DHCP server is actually functioning properly on two interfaces, each on its own subnet, with static leases, and WAN is receiving a DHCP address from Roadrunner.

    Any help is appreciated, and great job on everything.



  • Check next snapshot should be ok.



  • Now I get the following message:

    The DHCP Server can only be enabled on interfaces configured with static IP addresses.

    The interfaces not configured with static ip will not be shown.

    However, I still cannot configure the DHCP server on my two LAN interfaces that are giving out addresses.

    Also, if I type in the query string to configure the interface, ie, https://192.168.1.1/services_dhcp.php?if=opt1 instead of https://192.168.1.1/services_dhcp.php, I do not get the error message, but I have no options, and also still have no interfaces to choose from.



  • I tested this can you please attach a screenshot of what you are describing and the interfaces part of your config.xml?



  • Interfaces:

    <interfaces><lan><if>vr0</if>
    <ipaddr>192.168.1.1</ipaddr>
    <subnet>24</subnet>
    <media><mediaopt><bandwidth>100</bandwidth>
    <bandwidthtype>Mb</bandwidthtype></mediaopt></media></lan>
    <wan><if>vr3</if>
    <mtu><blockpriv><media><mediaopt><bandwidth>100</bandwidth>
    <bandwidthtype>Mb</bandwidthtype>
    <spoofmac>00:00:24:c3:5f:ee</spoofmac>
    <blockbogons><disableftpproxy><ipaddr>dhcp</ipaddr>
    <dhcphostname><pppoe_username><pppoe_password><provider><ondemand><timeout><pptp_username><pptp_password></pptp_password></pptp_username></timeout></ondemand></provider></pppoe_password></pppoe_username></dhcphostname></disableftpproxy></blockbogons></mediaopt></media></blockpriv></mtu></wan>
    <opt1><descr>Untrusted</descr>
    <if>vr1</if>
    <bridge><ipaddr>192.168.2.1</ipaddr>
    <subnet>24</subnet>
    <gateway><spoofmac><mtu><enable></enable></mtu></spoofmac></gateway></bridge></opt1></interfaces>

    Screenshots:
    http://mkindustries.us/1.jpg
    http://mkindustries.us/2.jpg



  • Either you cache has stale data or your system is not fully in sync with the changes, otherwise i cannot see how this is happening in your system since i cannot replicate in 3 systems here.

    Debugging info: to verify this check that the $tabscount is getting incremented in the loop after the form is declared since you seem to have to interfaces that should be shown there.


Locked