IPV6 Only IP i can use to RDP.



  • Well first i have been searching to try and find a post to my answer and have had no luck.Eyes crossed eyed at this moment from searching. I hope i posted this in the right section.

    So here is the issues i am having. i by defualt only use the IP address. i gone to the nat and allowed the ports i need open to be open. Well sadly it seems like none of them are working. I had a great idea to try my IPV6 IP address and well it worked just fine on my little RDP test. But the funny thing i didnt allow any rules for the IPV6 ip. So when i try with the regular IP nothing happens. For Ex. ip to RDP into PC gives me the classic cannot connect error. I feel that i may have configured something wrong or something. So im lost to what i need to search or test i need to run to make sure my regular IP address is even allowing anything to connect through with that.

    Ps. I have also disabled the IPV6 Ip and it still allowed the RDP with the IPV6 ip.



  • Maybe we should start with the basics and you explain on which interfaces you have the nodes connected? Then a little about your rules on those interfaces…


  • Rebel Alliance Global Moderator

    Worked from where?  What IPv6 address are you trying?  If your trying it from some other box on your same network that wouldn't even go through pfsense.  Unlike if you were trying a public IP which would require nat reflection to be setup if using from machine on same network.

    With P3R here - going to need a bit more info if you want any help..



  • so i have pfsense set up on a server running lime tech. I have  a 2 nic card dedicated to only the pFsense. then from there it goes to a dummy 8 port switch then out to 2 servers and 2 computers. The set up i have for pfsense is just the basic install wizard you do in the beginning.  the only thing ive done is just set up nat rules.

    So the reason why i created this post was because back when i had my asus router i was able to connect to my own Teamspeak for example with my ip , even though i was on the network and it would allow me to. I always used connecting to my own ip as a way to make sure the ports where working. but i was only able to with  wan ipv6 IP and not with the regular IP address. I did find out last night that on my teamspeak that my friends where able to connect but i found it weird that i couldnt unless going through my lan ip.


  • Rebel Alliance Global Moderator

    "but i found it weird that i couldnt unless going through my lan ip. "

    So you were hitting your public IPv4 1.2.3.4 address from a box on your network, lets call it 192.168.1.100..  That would be NAT reflection.  And unless you set it up in pfsense then no its not going to work.  Unlike many consumer routers that have it on by default.

    Here is the thing testing nat reflection is not a valid test that your port forward is going to work, be it with consumer router or pfsense.