Watchguard XTM 505 Firewall (NC2AE8) Bios corrupt ??? (SOLVED)



  • Hi,

    I have pickup a XTM 505 from Ebay, the seller had no knowledge of these devices
    and sold this device as "not working, for spareparts…" and that the LCD screen is blank.

    When the firewall arrived this morning, and after a quick visual check,
    i plugged in the powercable and the firewall shows only a green lighted LCD screen with no text.
    What i tried so far :

    BIOS reset + battery replaced
    Ram replaced
    Cpu replaced with a Celeron D
    Powersupply replaced
    Disconnected the CF card
    Disconnected the Cavium VPN accelerator card

    There are no beeps, even without Ram installed.
    The arm / disarm LED stays off
    The activity LED blinks a sec when power on.
    So i guess that are only 2 options left :

    1. Bios is corrupted
    2. Motherboard is dead

    Is this a common fault by these devices ?
    Is there a way for a Bios recovery in case of a faulthy Bios ?

    Many thanks in advance.

    Grtz
    DeLorean



  • It's alive, it's alive  ;D 8)

    After switching the cpu from another XTM 5 , the firewall works great.
    Just saved that thing from being a door stop for the rest of his life

    Grtz
    DeLorean