Azure pfsense deployment always fails



  • I have spent hours tying to get the netgate pfsense azure vm to deploy.

    most times it says

     "status": "Failed",
      "error": {
        "code": "ResourceDeploymentFailure",
        "message": "The resource operation completed with terminal provisioning state 'Failed'.",
        "details": [
          {
            "code": "OSProvisioningClientError",
            "message": "Username specified for the VM is invalid for this Linux distribution. Error details: Provisioning image FAILED Failed to create user account: adminuser (0x07).."[/code]
    
    it has worked twice but both times it worked I had tried to deploy with an ssh key instead of a password and then the keyfile does not work on the server end.
    I have tried many usernames that should work even just random strings always get the same error.
    
    anyone get this to work?
    


  • Hello Jdetmold,
    I am encountering the same issue as you. May I ask, were you able to get this to work? If so, how?
    Thanks in advance!