No connection between lan's after changing gateway



  • Hi,

    I have some problems with my pfsense 2.3.2.
    So i have 4 physical connections (nic's) 1 of these connections has 2 vlan's on it.
    Everything worked good i could connect with devices on the other nic's till i changed some stuff.
    I wanted to route al my traffic from 1 vlan with id 25 true a openvpn connection.
    This worked after i made a interface of the openvpn connection and made a rule that says allow to everywhere and gateway openvpn interface.
    Then i changed on my other lans the rules to gateway default wan.
    Since i have done this i can not connect between devices on different nic's / vlan's.
    Now i don't now how to fix this….
    I have made some screenshot's so you can see what i did.

    Image's : http://imgur.com/a/B29pv



  • @theptr:

    Then i changed on my other lans the rules to gateway default wan.
    Since i have done this i can not connect between devices on different nic's / vlan's.

    Why?
    With this rule you only allow traffic over WANGW, no other one.
    Set the WANGW as default and let the gateway option in the rules at "default".



  • Hi Viragomann,

    First thanks for helping me :) .
    I did what you say but when i reconnect my vpn client i have no longer internet on the interfaces…
    When i change the rules to WANGW i have internet but no connection between lan's.
    So is there something else i need to set ?

    @viragomann:

    @theptr:

    Then i changed on my other lans the rules to gateway default wan.
    Since i have done this i can not connect between devices on different nic's / vlan's.

    Why?
    With this rule you only allow traffic over WANGW, no other one.
    Set the WANGW as default and let the gateway option in the rules at "default".



  • screenshots :

    Notice the block rules are disabled



  • So I presume, your vpn client is your default gateway.
    Check the routes in Diagnostic > Routes and post it please.



  • Hi Viragomann,

    Here is a screenshot of the ipv4 routes.

    @viragomann:

    So I presume, your vpn client is your default gateway.
    Check the routes in Diagnostic > Routes and post it please.



  • Was the openVPN client connection established when this screenshot was taken?