VOIP phone will not call/receive calls when multi-modem is in bridge mode



  • Hello,

    I dont have much experience with VOIP, so please be patient with me.

    I have setup a virtual pfsense router on vmware esxi.
    My network setup is the following:

    Multi-modem: 10.0.0.138 / bridge mode
    ( IP telephone connected to Multi-modem )

    Switch
    pfSense router: WAN IP & 192.168.1.0/24 on LAN side

    When i put the multi-modem in bridge mode, the pfsense router gets the WAN ip address from the ISP : ) But as soon as i put the Multi-modem in bridge mode the IP telephone cant call or receive calls anymore.

    What do i have to do on the pfsense router to get this working?

    // Robert



  • You must connect your phone to the lan side of pfsense and do some port forwarding on pfsense, if does not work. What is the phone vendor and model?



  • You should check with your provider if your VoIP phone is supposed to work separately from their modem.
    They may have a separate voice vlan which is present on the modem only, i.e. it could be separate from the bridge you're using for Internet.



  • I think it's possible to use VLANs when modem is in bridge mode on WAN side.



  • @w0w:

    I think it's possible to use VLANs when modem is in bridge mode on WAN side.

    Most likely the modem will bridge only 1 'Internet' VLAN to it's LAN port(s).
    Even if pfSense will see all the VLANs (Internet, Voice, etc) on it's WAN the subscriber may face other problems.
    Just answered on another thread.



  • Tamsey,

    Is your ISP Telstra ? I know Telstra use 10.0.0.138 for some of their routers.

    Either way, your ISP should give you the VOIP details required for the phone. Some ISP won't share these details to avoid support nightmares.

    I had similar issues… some ISP provided routers hand out DHCP option 66 which is the address of a TFTP Server. Voip phones may pull their config from this server. When you bridge the ISP provided router pfSense will act as DHCP server instead and chances are you don't have configured option 66.
    Even when you configure option 66 things may not work. E.G. With Telstra Digital Office Technology the ISP provided router runs custom firmware which authenticates with their VOIP platform.
    I ended up having to use their crappy router and bridge pfSense instead.

    If your ISP does provide you with VoIP details and allows third party voip hardware you need to open required fw ports etc...

    Good luck!



  • VOIP phone will not call/receive calls when multi-modem is in bridge mode

    A real or pure modem is a bridge device by nature, only router that offers that modus could
    be set into the so called "bridge mode" but then they are loosing all their other capabilities
    they often came with or are sorted with, such as phone, WiFi or other functions, that's
    normal and all went fine!

    Multi-modem: 10.0.0.138 / bridge mode
    ( IP telephone connected to Multi-modem )

    You have here two ways you can walk on;

    • Let it be a router and use all the functions offered by that router such as the phone or WiFi options
      Router cascade that has its own network and then in the WAN interface of the pfSense a static IP from that network will work fine!
    • Set it into the so called "bridge mode" and loss all of the other functions, it acts then as a pure modem
      Not nice but it is really often the best way to use a device such as that together with pfSense
    • Alternatively you could buy a small Cisco phone adapter and set it up in front of the pfSense
      So you could call and surf but only for extra cost!


  • I ended up doing this:

    • Let it be a router and use all the functions offered by that router such as the phone or WiFi options
      Router cascade that has its own network and then in the WAN interface of the pfSense a static IP from that network will work fine!

    Now the IP phone works as normal :)

    Thank you guys for the replies in this forum post!



  • Beside the simplicity you now have double NAT and possible problems with port forwarding, possible bufferbloat on modem side, etc… but it's your choice anyway.  :-X


Log in to reply