Pfsense Vlan + Cisco SG300



  • boa noite a todos

    preciso da vossa ajuda, ja estou com este problema a alguns meses, estou a rodar o Pfsense numa maquina virtual ( Hiper-V) e estou  a tentar criar vlan numa unica porta do PFsense, estando a mesma conectada a um switch cisco sg300

    vou tentar descrever

    configuracao Pfsense:

    Vlan16 : 192.168.16.1
    Vlan32: 192.168.32.1

    dhcp

    192.168.16.10 - 192.168.16.20
    192.168.32.10 - 192.168.32.20

    firewall:

    open any nos duas Vlan

    Configuracao Cisco:

    Porta Ge10 - Porta de connexao ao Pfsense

    switchport mode trunk
    switchport trunk allow vlan add 16
    switchport trunk allow vlan add 32

    portas 1-4

    switchport mode access
    switchport access vlan 16

    portas 5-8

    switchport mode access
    switchport access vlan 32

    no entanto com a configuracao acima nao consigo colocar o equipamento em funcionamento

    alguem pode ajudar



  • Mostre as configurações das interfaces.



  • Pela sua config, a porta que vai para o pfsense está trunk, logo, é o software/equipamento que tem que dizer a VLAN que está usando (alias, as 2 interfaces do pfsense você está usando a mesma porta/placa de rede????)

    enfim, não basta setar a VLAN dentro do pfsense, você também tem que habilitar o vswitch do hyper-v para operar em modo trunk, e adicionar as vlan

    também tive que estudar este assunto quando implementei vlan aqui

    segue os comandos que usei, pesquisa por eles na internet se tiver duvida como funcionam

    Get-VMNetworkAdapterVlan -VMName pfsense

    Set-VMNetworkAdapterVlan -VMName pfsense -AllowedVlanIdList 2-100 -NativeVlanId 1 -Trunk -VMNetworkAdapterName LAN_Pfsense