BTX HALT error after second boot, USB only



  • Hello, all!  I am hoping I can pick your collective minds and try to solve this issue.

    HARDWARE: Zotac IONITX-F-E, latest firmware.
    USB: Multiple drives
    HDD: Samsung 850 EVO 120gb

    I can install the nanobsd vga version to USB stick and successfully boot and set everything up.  Anytime I reboot, that partition will get a BTX HALT error at boot time.  I can boot the secondary partition once.  It will have whatever settings were set during the previous partition's boot.  However, next time I reboot that one, I will also get a BTX HALT error upon boot.  Now, both partitions will have BTX HALT errors.  I rewrite the USB drive, and repeat.  I can boot once successfully from each partition, the second time I boot from a partition, I get a BTX HALT error.

    I have tried multiple USB drives.

    I am currently running on a samsung SSD, but I would prefer to run this off USB.  Is my hardware just too old?  I'm not opposed to upgrading (as if I need a reason to spend more money on my computer stuff  ;D),  but would prefer to exhaust all options prior.

    Thank you for taking the time to read this and I look forward to any help you may be able to provide.



  • That looks like it has an Atom 330 CPU, which is 64-bit. The 32-bit and NanoBSD for pfSense ends with the current 2.3.* release series. For 2.4 you would have to go to a 64-bit full install anyway.

    So you might as well do a full install of a 64-bit image - I would choose from either the 2.3.3-DEVELOPMENT or 2.4-BETA snapshots. Note that 2.4-BETA still has a few things outstanding, but actually it works well for 99.*% of use cases.



  • Does 2.4 support running off of USB?  Or if not, are you aware of a guide for optimizing USB boot for pfsense?

    Thanks!

    EDIT:  Did a full install to USB and it seems to be working.  I put tmp and var in memory, and set it to write only every 6 hours to disk.  Hopefully this will save my USB jump drive.

    Of note, and this is weird, if if set pfsense to use serial console, it crashes with BTX HALT again.  I had to completely re-install pfsense after I tried that and no amount of various USB jumpdrives with serial memstick written to it will boot.  Any ideas?