[SOLVED] LAN #2 not working



  • Hi,

    I use pfSense 2.3.2 on an Pentium Dual-Core CPU E5300. I'm pretty new to pfSense, but I have it up and running ok.
    My problem is that I can not get my LAN2 to work. WAN and LAN is on my Intel PRO/1000 card, and LAN2 on the build in ethernet port. WAN and LAN on the Intel card is working ok.

    On my LAN2 I get my IP, but no internet and I'm not able to ping pfSense.
    I have enable LAN2 interface, configured DHCP server and added a rule in firewall, see attachments, but no luck.

    Does any have an idea whats wrong?





    ![DHCP LAN2.JPG](/public/imported_attachments/1/DHCP LAN2.JPG)
    ![DHCP LAN2.JPG_thumb](/public/imported_attachments/1/DHCP LAN2.JPG_thumb)


  • LAYER 8 Netgate

    Yeah. The source network on your LAN2 rule should be LAN2 net not LAN net



  • Thanks, I'm getting closer.. :)
    Now I'm able to ping pfSense, but I still don't have internet access.

    What am I missing?




  • Check the outbound NAT settings. Is it set to automatic rule generation? And is there a rule for the LAN2 subnet in place on WAN interface?



  • Yes it's set to automatic rule generation. I suppose that's the correct setting?

    There is no rules on the WAN interface. Do I need that?

    ![WAN rules.JPG](/public/imported_attachments/1/WAN rules.JPG)
    ![WAN rules.JPG_thumb](/public/imported_attachments/1/WAN rules.JPG_thumb)



  • I meant the outbound NAT rules. Though it is set to automatic mode, there are shown rule below. Please post these.



  • These?

    ![NAT rules.JPG](/public/imported_attachments/1/NAT rules.JPG)
    ![NAT rules.JPG_thumb](/public/imported_attachments/1/NAT rules.JPG_thumb)



  • In these rules the LAN2 IP adress say the same as my LAN subnet.

    LAN is 192.168.30.x
    LAN2 is 192.168.40.x

    Can that be the problem?



  • Yeah, that would be the issue.
    Maybe pfSense can generate the correct rules automatically. To do so try switch the rule generation to manual and hit save, then delete all rules, save it and switch back to automatic mode.



  • Tried to do that. Deleted everthing in manual, switched back to auto and the same rules where generated. Still the same IP adress..

    Also tried to set it in manual and changed the IP to 192.168.40.0/24, but then I lost the connection on my LAN subnet. It did't work on LAN2 either.



  • That rules are not correct for two LANs and should have a reason.
    Have you set gateway in LAN2 interface settings?

    Otherwise you can switch outbound NAT to hybrid mode and add the LAN2 rule manually.
    But you have also rules for LAN2 interface there which are presumable not wanted. These rules translate packets source address to LAN2 address when packets leave pfSense on this interface.



  • No, I have not set an gateway in LAN2 interface settings. I tried to set it once while faultfinding, but it didn't work.

    Do I have to make the new rules on LAN or LAN2? There is already automatic rules for LAN2.
    Should there be rules for LAN shown here as well?




  • No, if the is no special reason for that, you need neither an outbound NAT rule for LAN interface nor for LAN2.

    Presumably the gate is still set in pfSense, but not assigned to LAN2. Check and delete it in System > Routing > Gateways.

    If the LAN2 rules are not gone, switch your outbound NAT to manual rule generation, then delete it.
    Add a new rule, select WAN interface and at source enter your LAN2 subnet, leave the other settings to its defaults and save it. Now you should have internet access.



  • Finally  :D :D

    It was the gateway that caused this problem. I deleted it and turned back the automatic outbound rules.

    Then it worked as it should

    Thanks a lot viragomann!!


Log in to reply